Subject: Re: CCL:SMILES databases - ERROR

From: Richard Bone <[email-masked]>
Date: Wed, 23 Jul 1997 13:54:44 +0100

Apologies:  in sorting through my replies, I mis-attributed authorship.

The message from Wolfgang Utz concerned a suggestion to use a structure-
editor at http://schiele.organik.uni-erlangen.de

Sorry again;  there was no attempt by anyone to claim authorship for anything
they hadn't done.

Richard Bone

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
|  Richard G. A. Bone,  Ph.D.      |                                   |
|  Senior Computational Chemist    |                                   |
|  Proteus Molecular Design Ltd.   |  Tel:   +44 (0)1625 500555        |
|  Lyme Green Business Park        |  Fax:   +44 (0)1625 500666        |
|  Macclesfield,   Cheshire        |  Email: [email-masked]        |
|  United Kingdom      SK11  0JL   |  Web:   http://www.proteus.co.uk  |
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "Wolf-Dietrich Ihlenfeldt" <[email-masked]>
Date: Wed, 23 Jul 1997 14:46:29 -0600

On Jul 21, 12:08, Richard Bone wrote:
> Subject: CCL:SMILES databases - summary
>
> Following up on my enquiry about SMILES databases last week, here is a brief
> summary of the responses.
>
> They fell into 3 different categories (besides the inevitable "please send us
> the answers ... "):
>

> 3) Examples of SMILES databases already 'out there'.
>
>    a) 8,000 small organics.
>       Contact J. Eric Slone ([email-masked]).
>
>    b) Database of organic compounds (Possibly in SMILES, and probably used
for
>       QSAR).
>       Contact Lowell Hall ([email-masked]);  communicated by Tod Story,
>       ([email-masked]).
>
>    c) First 4,000 (non metal-containing) entries of the NCI database.
>
>       Supplied by Wolfgang Utz ([email-masked]).

WHAT IS THIS?

Wolfgang Utz DID NOT MAKE THESE COMPOUNDS AVAILABLE. He was
not involved at all at any step. I (Wolf-D. Ihlenfeldt) did all the
steps of the conversion myself, with my own software. Please refrain
from claiming authorship for work you do not have participated in!

>       Available by FTP:
>       (ftp://schiele.organik.uni-erlangen.de/pub/nci/nci4000.smi.gz)
>

This is the server I administer. Wolfgang Utz does not even
have an account here.

-- 
Dr. Wolf-D. Ihlenfeldt
Computer Chemistry Center, University of Erlangen-Nuernberg
Naegelsbachstrasse 25, D-91052 Erlangen (Germany)
Tel (+49)-(0)9131-85-6579  Fax (+49)-(0)9131-85-6566
---
The three proven methods for ultimate success and fame:
1) Nakanu nara koroshite shimae hototogisu
2) Nakanu nara nakasete miseyou hototogisu
3) Nakanu nara naku made matou hototogisu

---

From: "Wolf-Dietrich Ihlenfeldt" <[email-masked]>
Date: Wed, 23 Jul 1997 17:02:48 -0600

> In addition, I came across a web-site at Pomona College which contained a
> number of files of compounds organised by molecular empirical formula, and
> containing their SMILES strings.
>
> http://clogp.pomona.edu/medchem/chem/master/mf/ghindex.html
>
> It does not appear to be possible to download these 'in batch', but it is a
> most \\formidable\\ source of data.

Well, regularly structured websites can be easily milked:

Hack, hack, hack...

----------------------------
#!tcl

exec wget -r --no-parent http://clogp.pomona.edu/medchem/chem/master/mf/
set filelist [exec find clogp.pomona.edu/medchem/chem/master/mf/ \
	-name *.html -print]
foreach file $filelist {
   set fh [open $file]
   set data [read $fh]
   while {[regexp -nocase -indices "<dt>smiles\[ \t\n\]+<dd>(\[^\t\n\]*)\[
\t\n\]+<dt>full name\[ \t\n\]*<dd>(\[^\t\n\]*)\[ \t\n\]*" $data dummy sidx
nidx]} {
      lassign $sidx sstart sstop
      if {$sstart>$sstop} break
      set smiles [string trim [crange $data $sstart $sstop]]
      lassign $nidx nstart nstop
      if {$nstart<$nstop} {
         set name [string trim [crange $data $nstart $nstop]]
      } else {
         set name "Unnamed"
      }
      puts "$smiles\t$name"
      set data [crange $data $nstart+5 end]
   }
   close $fh
}
exec rm -r clogp.pomona.edu
-------------------------------------------------

You need tclx, wget and find on your machine to execute this.
The program yields 30914 structures in an hour or so (limited
by the speed of web access).

Is this politically correct to execute? I don't know, the website
is not very clear about this. To avoid problems,
please do not ask me for the dataset.