Subject: xmol.sgi

From: [email-masked] (Anne-Marie Kelterer)
Date: Mon, 25 Aug 1997 10:34:13 +0200

Dear CCL-Netters,
I had some problems to run the XMol-program on a SGI.
After getting the xmol.tar and xmol.sgi files and after
installing them, the program aborts with the message:
Cannot execute binary file
/usr/local/bin/xmol - Exec format error
The privileges of this exe-file were ok. 
Can someone help me with his practical experience?
Thanks in advance. 
Dr. Anne-Marie Kelterer
Institut fuer Physikalische und Theoretische Chemie
Technical University of Graz
Brockmanngasse 27, A-8010 Graz, Austria
Fax: +43 316 873 8720
email: [email-masked]

---

From: Stefan Grzybek <[email-masked]>
Date: Mon, 25 Aug 1997 13:02:08 +0200 (MDT)

> Can someone help me with his practical experience?

The binary format of the xmol executable is probably in COFF-format
(run 'file /usr/local/bin/xmol'). COFF binaries are only supported
by the operating system up to IRIX 5.3. IRIX 6.x can't run those
binaries :-(. There is _NO_ possibility to have COFF-binaries execute
under IRIX 6.x. You have to try to get an ELF-executable instead.

Hope this helps,
Stefan Grzybek
---
| Dr. Stefan Grzybek   email: [email-masked]       |
|                         [email-masked] |
|                 http://athena.chemie.uni-erlangen.de/~grzybek |
| Universitaet Freiburg, Institut fuer Biologie II, Biochemie   |
| der Pflanzen, Schaenzlestr. 1, D-79104 Freiburg, Germany      |
|     Voice: +49 +761 203-2703 or -2796, Fax: +49 +761 203-2601 |

---

From: Fenglou Mao <[email-masked]>
Date: Tue, 26 Aug 1997 08:52:14 -0700 (PDT)

> Can someone help me with his practical experience?

  Some applications run in IRIX5.3 can't run in IRIX6.3, if you 
error is what I think, then you have two choices:
  1:Compiled it in IRIX5.3(use 5.3's compiler),run in IRIX5.3.
  2:Compiled it in IRIX6.3(use 6.3's compiler),run in IRIX6.3.

Sincerely Yours,

FengLou Mao
*******************************
ADD:Mr. FengLou Mao
    Peking University
    BeiJing
    P.R.China
Tel:86-10-62751490
Fax:86-10-62751725