Subject: Re: CCL:linux memory availability

From: Matt Challacombe <[email-masked]>
Date: Wed, 30 Sep 1998 14:28:16 -0600 (MDT)

Hi Adrian,

If I understand your question properly, LINUX only sees 64MB, while
you have 128.  To get it to see the full 128, put the following line in
/etc/lilo.conf:

append="mem=128"

Then at the prompt type 

lilo

and reboot.

Cheers, Matt

+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
Matt Challacombe
Los Alamos National Laboratory    http://www.t12.lanl.gov/~mchalla/
Theoretical Division              email: [email-masked]
Group T-12, Mail Stop B268        phone:   (505) 665-5905
Los Alamos, New Mexico  87545     fax:     (505) 665-3909
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

On Tue, 29 Sep 1998, Adrian Turjanski wrote:

> 
> Dear CCLers
>   I'd like to know whether is possible to set the memory availability
>   for each user in a linux environment. We have a machine with 128 MB
>   RAM but only allows each user to use up to 64 MB.
>   If someone can help us, we'll thank a lot.
>   Regards,
>   Adrian 
> 
>   Adrian Turjanski
>   Universidad de Buenos Aires
>   Argentina
> 
> 
> ---
> Administrivia: This message is automatically appended by the mail exploder:
> [email-masked]: Everybody | [email-masked]: Coordinator
> [email-masked]: HELP CHEMISTRY or HELP SEARCH | Gopher: www.ccl.net 73
> Anon. ftp: www.ccl.net   | [email-masked] -- archive search
>              Web: http://www.ccl.net/chemistry.html 
> ---
> 
>

---

From: Victor Lua~na <[email-masked]>
Date: Wed, 30 Sep 1998 23:08:28 +0200 (METDST)

> From: Adrian Turjanski <[email-masked]>
> Subject: CCL:linux memory availability

>   RAM but only allows each user to use up to 64 MB.

If you enforce users to run their calculations through a queue system like
NQS, you can define resource limitations for each type of queue: memory,
disk, cpu time, etc.