Subject: CCL:a good graphing analysis package?

From: TOPPER ROBERT <[email-masked]>
Date: Wed, 21 Oct 1998 09:36:14 -0400 (EDT)

For all plots and curve fits two-dimensional,
nothing beats KaleidaGraph IMHO. It is an incredibly
fast, robust program available for Macs and PCs.
Moreover it is easy to use - I have shown freshman
students how to make fairly complex plots in minutes.
It is trivial to add error bars (x and/or y axis)
to some or all of the points of a data set. 
You can easily define your own curves for plotting to
compare with your data, use their pre-set fitting
routines (which are quite robust) or define your own
function for fitting.
The graphics it produces are camera-ready when printed
on a laser printer. In short:
I have been using KG for many years and highly recommend it.
It's available from Synergy Software, and is CHEAP with
an academic discount. (www.synergy.com; (610) 779-0522 is the
number (unless it's changed since last time I called).
KaleidaGraph will run just fine on a Mac Classic (I do this sometimes
in a pinch) and is screamingly fast on even a minimal PowerMac.

However, it (sadly) cannot do 2D plots. For such things,
I typically use Mathematica, MathCAD or a similar package
(which will not run on some of my older 000-040 Macs).
Both are available for PC and Mac platforms.
Mathematica can do many of the 2D plotting things one would
need to do, as can MathCad.
However, I doubt whether those packages can be easily used to add
error bars to data points (although I'm sure someone out
there will tell me if I'm wrong. :-) ), so I can't recommend
them as your sole solution or 2D and 3D plotting (since I always
include error bars in my calculations).

SigmaPlot can do all you want, but last I heard it was not available
on both Mac and PC platforms. You might consider running it on
a G3 PowerMac using SoftWindows or some similar product - the performance
should be decent and one program will do everything you need.

*****************************************************************************
Robert Q. Topper                        email:   [email-masked]
Asst. Professor of Chemistry            phone:   (212) 353-4341
The Cooper Union                        fax:     (212) 353-4378 
51 Astor Place                          subway:  take the 6 to Astor Place 
New York, NY 10003                               and you're there!
                 http://www.cooper.edu/engineering/chemechem/
*****************************************************************************
The Cooper Union for the Advancement of Science and Art is a tuition-free
college in Greenwich Village, at Cooper Square and Astor Place.
*****************************************************************************

Forwarded message:
> Date: Wed, 21 Oct 1998 16:04:46 +1000
> To: [email-masked]
> From: "Kieran F Lim (Lim Pak Kwan)" <[email-masked]>
> Subject: CCL:a good graphing analysis package?
> 
> We are seeking a dual platform (Mac and PC) graphing and analysis
> package. This should have the ability to do
>  - curve fitting (including user-defined functions)
>  - 2-d and 3-d plots
>  - plots suitable for insertion into both hardcopy and electronic
>    documents (not everthing does the latter well!)
> 
> Can you recommend a package based on your experiences?
> 
> Sorry if you get multiple copies of this message.
> 
> Thank you,
> 
> Kieran
> 
> ------------------------------------------------------------
>  Dr Kieran F Lim             Biol. and Chemical Sciences
>  (Lim Pak Kwan)              Deakin University
>  ph:  + [61] (3) 5227-2146   Geelong          VIC   3217
>  fax: + [61] (3) 5227-1040   AUSTRALIA
>  mailto:[email-masked]    http://www.deakin.edu.au/~lim  
>

---

From: David van der Spoel <[email-masked]>
Date: Wed, 21 Oct 1998 16:45:28 +0200 (MET DST)

After this bombardment of e-mails on comercial graphics packages, I would
like to suggest using  xmgr for your 2D graphics. 
It is easy to use, and includes non-linear curve fitting.
It is free software and runs on any UNIX implementation including
Linux, and therefore will run on your PC and Mac machines.

Groeten, David.
________________________________________________________________________
Dr. David van der Spoel		Biomedical center, Dept. of Biochemistry
s-mail:	Husargatan 3, Box 576,  75123 Uppsala, Sweden
e-mail: [email-masked]	www: http://zorn.bmc.uu.se/~spoel
phone:	46 18 471 4205		fax: 46 18 511 755
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++