Subject: Re: CCL:a good graphing analysis package?

From: Nick DeMello <[email-masked]>
Date: Wed, 21 Oct 1998 21:06:49 -0700

I'd like to second the suggestion you take a look at
      Mathematica.  It's an incredibly powerful and adaptable
      calculation and graphics programming environment.

    Since you specifically asked about print quality graphics
      let me also toss into the mix the suggestion that you
      explore an add on for Mathematica made by Conix
      called "Conix 3D Explorer"--it's an OpenGL based
      rendering engine.  When used with Mathematica you can
      create some truly spectacular, print quality, images
      --makes eye catching 3D plots.

    (FYI, I'm not associated with either Wolfram or Conix
      --just enthusiastic about the tools they offer)

At 2:31 PM +0800 10/21/98, Paul Abbott wrote:
>At 2:04 PM +0800 21/10/98, Kieran F Lim (Lim Pak Kwan) wrote:
>
>>We are seeking a dual platform (Mac and PC) graphing and analysis
>>package. This should have the ability to do
>> - curve fitting (including user-defined functions)
>> - 2-d and 3-d plots
>> - plots suitable for insertion into both hardcopy and electronic
>>   documents (not everthing does the latter well!)
>>
>>Can you recommend a package based on your experiences?
>
>Mathematica does all of these things well (and more).  You can find out
>more about Mathematica at
>
>	http://www.wolfram.com
>
>Some examples of chemistry applications of Mathematica can be found at
>
>	http://www.wolfram.com/engineering/users.html
>
>and some research papers in Chemistry and Chemical Engineering that have
>used Mathematica are listed at
>
>	http://www.wolfram.com/papers/chem.html
>
>In addition, I find it to be an excellent teaching tool. Hope this helps.
>
>Cheers,
>	Paul
>
>
>____________________________________________________________________
>Paul Abbott                                   Phone: +61-8-9380-2734
>Department of Physics                           Fax: +61-8-9380-1014
>The University of Western Australia
>Nedlands WA  6907                     mailto:[email-masked]
>AUSTRALIA                        http://www.physics.uwa.edu.au/~paul
>
>            God IS a weakly left-handed dice player
>____________________________________________________________________
>
>
>
>-------This is added Automatically by the Software--------
>-- Original Sender Envelope Address: [email-masked]
>-- Original Sender From: Address: [email-masked]
>[email-masked]: Everybody | [email-masked]: Coordinator
>[email-masked]: HELP CHEMISTRY or HELP SEARCH | Gopher: www.ccl.net 73
>Anon. ftp: www.ccl.net   | [email-masked] -- archive search
>             Web: http://www.ccl.net/chemistry.html

____Nicholas C. DeMello, Ph.D.________________________________________
 Editor of MacTech Magazine, for Macintosh Developers and Programmers
     http://www.mactech.com/
                                       _/   _/  _/  _/_/_/   _/   _/
                                      _/_/ _/  _/  _/   _/  _/_/_/
  mailto:[email-masked]          _/ _/_/  _/  _/       _/ _/
    http://www.nick.demello.com/    _/   _/  _/   _/_/_/  _/   _/

---

From: Richard Gillilan <[email-masked]>
Date: Thu, 22 Oct 1998 08:44:30 -0400

>       calculation and graphics programming environment.

I'll put in a vote for Matlab. Although both of these
packages now have similar functionality, Matlab started
as a numerical analysis package and has retained leadership in
this area (those who are more familiar with Mathematica, 
please feel free to argue). Mathematica began as a symbolic math
package and has pretty good 2D and 3D graphics by comparison.
I really like Matlab's scripting language however. It's open API
allows us to integrate it tightly with other code. 
Recent introduction of more advanced data structures etc. is very
appealing too. One can also convert Matlab scripts into C code 
for better performance. Why have all the overhead for symbolic
math when you really want to do numerical operations like
curve fitting? Just my personal preference.

Richard Gillilan
Cornell Theory Center