Subject: Charmm DCD file format

From: Yongxing Liu <[email-masked]>
Date: Wed, 18 Nov 1998 14:51:14 -0500 (EST)

Dear sir,

I am helping to debug a program which can convert amber trj file to Charmm
DCD format and further used by Xplor. I have no experience with Charmm
and Xplor though we have both packages installed. Basically I have two
questions:

(1) Would some one please tell me where I  can   find the DCD header
format description without digging into the code?(e.g what's the meaning
of the first 20 header varibles and their domain?)

(2) Can Xplor read in charmm DCD without any modifications?

Thanks a lot in advance.

Yongxing Liu
Department of Chemistry
Wesleyan University
Middletown CT 06459
Tel: 860-685-2777

---

From: Andrew Dalke <[email-masked]>
Date: Wed, 18 Nov 1998 11:31:47 -0800

Yongxing Liu <[email-masked]> asked:
> I am helping to debug a program which can convert amber trj file to
> Charmm DCD format and further used by Xplor.

You might want to look at VMD <http://www.ks.uiuc.edu/Research/vmd/>.
It contains C code to read/write binary DCD files on SGIs and
HPs (the format is machine dependent).  The Amber group distributes
a free library for reading/writing parm files and the VMD
distribution includes the library in its distribution.

The end result is you should be able to use VMD to read the
Amber file then write the results to a DCD file.   Or you can
strip the code out of VMD and roll your own solution.  A couple
of other package (most notably MMTK) have taken that route.

> (2) Can Xplor read in charmm DCD without any modifications?

I don't recall there being any problems.  XPLOR ignores one 
of the fields that CHARMm defines.  If there is a problem,
you can use the same DCD library routines from UIUC to touch up
the appropriate element.

						Andrew Dalke
						[email-masked]