Subject: 3D Graphics Accelerators as computational tools

From: Darren Andrews <[email-masked]>
Date: Wed, 25 Nov 1998 12:19:43 +0000

Has anyone thought of using the awesome floating point performance of 3D
graphics accelerators in computational chemistry?  A decent 3D Voodoo II
card is theoretically capable of about 9Gflops/sec, two of them together
give 18Gflops/sec, and with an AGP interface can talk to the cpu at over
500M/sec.  Is it possible to harness this power, and would it even be
worthwhile trying?

Darren Andrews.

PostGraduate Student,
School of Chemistry,
University of Leeds,
Leeds.
LS2 9JT.
England.

[email-masked]

Tel: 0113 233 6594.
Fax: 0113 233 6565.

---

From: "Kenneth W. Egan" <[email-masked]>
Date: Wed, 25 Nov 1998 08:02:42 -0600 (CST)

> 500M/sec.  Is it possible to harness this power, and would it even be

   This brings up several issues....
   
     1). Do the chips actual implement IEEE floating point, or is it
         proprietary...like 24.8 or 22.10 ( fixed )

     2.) Practical only in Geometry processors. However, to use each
         FP multiplier, as that, requires making sure none of the
         other pipeline units are operative, or at least those
         stages are not interactive.... World scaling, vertex
         transformation, lighting, clipping....etc. The matrices
         are usually hard coded, so initialization may require
         significant setup.

     3.) End result----> must do setup, AGP write to adapter
         then AGP read....max theoritical bandwidth is thus
         250 MFLOPS regardless of the number of FP multipliers
         in the chip. 

     The IBM/motorola Power 630 is capable of 1 FP op/cycle,
     the newest chips can achieve 450 MFLOPS. I think the 
     new IMAC has a 630...not sure.

     Not a bad line of reasoning though.

     Ken Egan
     IBM 3D VLSI design
     Austin