Subject: Re: CCL:news group

From: Jian Wang <[email-masked]>
Date: Fri, 07 May 1999 16:03:03 -0700

Hello,
Thanks for all expert advices regarding the segmentation fault posted
yesterday.
I suspected the segmentation fault comes from the array size, because it
occurs when I increased the array size to around (220X659)=144980 under
double precision (see the following output from the dbx).
But If I test a simple code with an array of this size, it doesn't report
error. My machine has still got a lot memory available (more than 2gb), so
it is not possible the memory is run out on the machine.  Some friend
suggested it might be the limit on stack size which restrict the
declaration of memory, which I think it is probable if no only the
variables, but subroutine calls might also require stack.
Can any expert give an detail as to how the stack, heap work in Fortran77?

Jian

ps: the test result:

(dbx) r
signal Segmentation fault at    [current:69 ,0x120003d94]         dimension
Cmo1b(nocc-1,nbf),Cmo2b(nocc-1,nbf)
(dbx) where
>  0 current(NATOMS = 109, NOCC = 220, NBF = 659, NSHELL = 399, NP = 1073)
["current.for":69, 0x120003d94]
   1 main() ["current.for":40, 0x1200030b8]
   2 main() ["for_main.c":203, 0x1200029cc]

---

From: "Kenneth W. Egan" <[email-masked]>
Date: Fri, 7 May 1999 20:36:40 -0500

If you're running some derivative of unix......... use ulimit

             ulimit -s XXXXXX  sets stack to XXXXXX KB's
             ulimit -d XXXXX  sets data area to XXXXX KB's
             ulimit -m XXXXX ssets physical mem

            might try ulimit -s unlimited -d unlimited -m unlimited
----- Original Message -----
From: Jian Wang <[email-masked]>
To: <[email-masked]>
Sent: Friday, May 07, 1999 6:03 PM
Subject: CCL:news group

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
>
>
>
>
>