Subject: XML in output/input files for Comp. Chem. Codes

From: Jan Labanowski <[email-masked]>
Date: Tue, 18 May 1999 16:48:54 -0400 (EDT)

Partially from conviction, and partially to prevent a flame war on the
list, I want to point out that we will have to live for a long time
with the presence of "legacy formats". 
So, let the programs produce and process legacy formats too, but I would
love to have also a file:
  output.xml 
produced, and file
  input.xml
accepted for input. The number of various 
   something2somethingother.pl (awk, sed, etc.)
scripts which I produced over the years is in hundreds. I wish I could have
spent this time reading something interesting or thinking about the data
I produced.

In short... I do believe that we cannot abandon legacy formats overnight.

It would make me use a few #@!&? words exactly the same way, as when
the new release of "well known" quantum chemistry workhorse comes out.

However, I would be happy, if beside the *.out, I also had *.xml.
It does not have to be a fancy XML... Let them design their own tags
and attributes to kill the competition and to feed the sense of being right,
but let the tags be closed and properly nested.  I will do the rest.
Over the years I lost any hope that Computational Chemistry formats for
input or output can be standardized.  Egos, and commercial interests will not
allow it. But at least, if there was a companion XML file with the same info
as in traditional legacy input or output file, it would make my life easier
(as well as many others, I hope). Disk space is cheap, and putting
additional WRITE or fprintf statements is not a big deal.

The funny thing is that chemists were the first to see the opportunity
with Peter Murray-Rust and Henry Rzepa advocating CML.
And what? Depends whom you ask, but on average, we as a professional
group can claim foresight, but not wide spread practice.

Jan
[email-masked]

Jan K. Labanowski            |    phone: 614-292-9279,  FAX: 614-292-7168
Ohio Supercomputer Center    |    Internet: [email-masked] 
1224 Kinnear Rd,             |    http://www.ccl.net/chemistry.html
Columbus, OH 43212-1163      |    http://www.ccl.net/

---

From: "Rzepa, Henry" <[email-masked]>
Date: Tue, 18 May 1999 23:19:23 +0100

>group can claim foresight, but not wide spread practice.

Since Jan was kind enough to quote Peter and myself, 
I note here that Part 1 of an article on  XML
and CML   just been submitted for publication in  JCICS
by Peter and myself (but not yet refereed or accepted). 

Due to the policy of the ACS, I cannot  place the entire article
on the Web, since that would constitute prior publication.
However, I will seek guidance from Bill Milne of JCICS to
see whether the  CML tagset, the attribute list, six examples and the  DTD
could be published in the interests of the community
and of  "OpenSource" software. Peter has also written around
8 "legacy" to CML converters (ie Gaussian,  GAMESS,
MOPAC, PDB,, etc etc)  and he is happy to make these
available to anyone who wishes to test/improve/add to them.
This will all be made available via
http://www.xml-cml.org/ 
 Finally, we hope to be shortly releasing an
XML-CML repository server with some interesting and we
hope novel features, which will really allow the true potential
of  XML  to be demonstrated.

We would invite the community to comment on this formal  CML
definition, and to contribute to the development of chemical markup
languages in general  in the sprit of  OpenSource.

I might also add that CML was first
proposed in August 1995 (well before XML itself!)
 and a special version of  MOPAC
capable of producing program output in  CML was made available,
thus anticipating the thread of this discussion.
Its still up at  http://www.ch.ic.ac.uk/cml/ where you can try it
for yourselves. The CML was a  very early draft, and might differ
slightly from the version proposed in the JCICS article. In particular,
it was not  XML conformant for obvious reasons.

Finally, I am sure you are all aware of it, but the principle  XML discussion
forum is at  http://www.lists.ic.ac.uk/hypermail/xml-dev/
and contains some  13,000 postings from Feb 97 to present.
 It is indexed, so anyone
wishing to search for specific terms can do so.

Henry Rzepa. +44 171 594 5774 (Office) +44 171 594 5804 (Fax)
http://www.ch.ic.ac.uk/rzepa/