Subject: CCL:XML as program output?

From: Razvan Caracas <[email-masked]>
Date: Wed, 19 May 1999 00:17:38 +0200

Hello everybody,

I think that XML format (I saw its
description only now) may become a
good inter-exchange file format.
See for example the *.CIF files (=
Crystallographic Information File,
documented at http://www.iucr.ac.uk)
that is widespread, read and written
by the most of the crystallographic
softwares available now. It is a
file format with definitions for
every parameter etc just like
XML might be.
The problem is, I think,  not
neccesarily to find and to accept
definitions like

For example, energies might be marked up as:
<energy type="nuclear repulsion" units="Hartrees">101.8303753234</energy>
<energy type="uhf" units="Hartrees">-190.784836075</energy>

the problem is in finding ways to
use applet-like procedures available
on different OSs. I mean, to be able
to load for example 3D rendering
procedures to visualize a
molecule/crystal. Or to treat
several *.xml files in the same time
and to compare the values of the
same parameters. This should be more
important than just define data
types (which eventually be very well
made in "text" files).

Also, to change the output formats of dozens of programs to a format that
is not very widely used, especially considering that not everyone is
using the same OS and same versions of programs, is daft.

Longer we wait harder would be to
impose a generally accepted file
format. And it is not necessarily
needed to eliminate the other
formats. Besides as far as I see a
text/XML file may be read by any OS
and machine. The question is if we
can really use XML on different OSs.

Sincerely,
Razvan

------------------------------------------------------------------------------------
Razvan Caracas

Universite Catholique de Louvain
Department of Geology and Department of Physical-Chemistry and Physics of Materials
Batiment Mercator                       tel: 0032-(0)10-472855
3,pl. Louis Pasteur                     fax: 0032-(0)10-472429
1348 Louvain-la-Neuve                   Belgium
e-mail:         [email-masked], [email-masked]
------------------------------------------------------------------------------------

---

From: Konrad Hinsen <[email-masked]>
Date: Wed, 19 May 1999 14:54:34 +0200

On Tue, 18 May 1999, Wolf-Dietrich Ihlenfeldt wrote:

> with platform independence. XML IS platform-independent,
> since it is ASCII and does not suffer from  any byte ordering
> or FP representation issues.

Small correction: XML is Unicode, not ASCII. Which doesn't make it any
less platform-independent, but somewhat more difficult to deal with.
XML files that contain only ASCII characters and use UTF-8 encoding
are of course ASCII files, and therefore writing valid XML doesn't
require much effort. However, an XML-compliant parser must be able
to deal with other Unicode encodings as well.
-- 
-------------------------------------------------------------------------------
Konrad Hinsen                            | E-Mail: [email-masked]
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-2.38.25.55.69
Rue Charles Sadron                       | Fax:  +33-2.38.63.15.17
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais
-------------------------------------------------------------------------------