Subject: Re: CCL:XML as program output?

From: Sven Bovin <[email-masked]>
Date: Wed, 19 May 1999 08:30:12 +0100 (NFT)

Or not running Windows at all, for that matter.

************************************************************
*Sven BOVIN                  [email-masked]*
*----------------------------------------------------------* 
*labo kwantumchemie |IJzerenmolenstr 26|                   *
*Celestijnenln 200F |   bus 116        |Wampenberg 88      *
*B-3001 HEVERLEE    |B-3001 HEVERLEE   |B-2370 ARENDONK    *
* Belgium           | Belgium          |Belgium            *
*tel +32(0)16 327380|                  |tel +32(0)14 678310*
*fax +32(0)16 327992|                  |fax +32(0)14 678310*
************************************************************

On Tue, 18 May 1999, Richard Wood wrote:

> I still say why convert many file formats to one if you don't have to/not 
> all applications curently being used will handle them.
>   
> It's like assuming that everyone using a PC is using Windows 95/98, when 
> the fact is that some are still using Windows 3.1.
> 
> Richard
>

---

From: "Wolf-Dietrich Ihlenfeldt" <[email-masked]>
Date: Tue, 18 May 1999 23:19:30 -0600

On May 18, 16:01, Dmitry Khoroshun wrote:
> Subject: CCL:XML as program output?
> According to Richard Wood:
> >
> > But rasmol reads a "text" file format!  Why change it and other programs
> > that already read text files?  That doesn't make any sense to me.
>
> This indeed makes not much sense. What use is of introducing a "type"
> of the energy, like "nuclear repulsion"? You still have to read and
> understand it, not just click on it with a mouse. Unix scripting
> possibilities allow for many many things like sorting or similar.

Most output formats of QM programs are actually very unsuitable for
any scriped processing, since it is difficult to precisely locate the
information you need. A hyphotical example
not far from the truth:

These charges you look for appear 5 lines (6 on AIX)
after the magic keyword 'hooray' (provided nobody accidentially
used this as job title), in multiple sets of 5-column 3-row output
(7 columns if user selected 132-char paper output - this selection
appears nowhere in the output -, 4 rows per set if option 'yeah'
was selected, but not in conjunction with
option 'nay', which results in  the insertion of
something completely different inbetween these lines),
there is one space between the columns (on AIX, no
space, but fixed column width, version-dependent magnitude),
rows are separated by an empty
line (before version 6.0, is was '---', after V7.0, every third
row contains the program name), the end of this section can
be easily identified because there are two consecutive
empty lines (except on Linux with f2c V1.x, - not 2.x-  there was
a bug in the interpretation of the format statement, and multiple
empty lines are merged into one))

And you want to write a simple script to SORT this mess?
BTW, there are a number of powerful tools for XML for data extraction etc.
already available. Visit alphaworks at IBM.

 And of course.
> programs such as molden have no problems with reading text files.

Have you ever looked at the code which does this? It is EVIL!
No structure, no grammar, just a jungle of ad-hoc hacks.
I do not want to maintain it! (And continuous maintenance
is indispensible with those unstructured formats. because
everythign will break with the next release)

>
> I guess the next step would be implementing surrounding sound into Gaussian.

Only after the output has been cleaned up.

>
> Sincerely,
> Dmitry Khoroshun
> [email-masked]
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
>
>-- End of excerpt from Dmitry Khoroshun

--
Dr. Wolf-D. Ihlenfeldt
Computer Chemistry Center, University of Erlangen-Nuernberg
Naegelsbachstrasse 25, D-91052 Erlangen (Germany)
Tel (+49)-(0)9131-85-26579  Fax (+49)-(0)9131-85-26566
---
The three proven methods for ultimate success and fame:
1) Nakanu nara koroshite shimae hototogisu
2) Nakanu nara nakasete miseyou hototogisu
3) Nakanu nara naku made matou hototogisu