Subject: autodock3

From: Administrator <[email-masked]>
Date: Fri, 2 Jul 1999 17:06:18 +0200

Hi all,

	Autodock3 was successfully compiled on a DEC alpha with compiler cxx and -oldcxx option.
	Although, I receive a 'segmentation fault' message when program stops at docking parameter:
		DPF>  move   xk2A.pdbq    .

	I appreciate any help.

---------------------------------------------------------------------------------------------------------------------
Verschelde Jean-Luc

Department of Medical Protein Research (VIB 09) and Department of Biochemistry,
 Faculty of Medicine, University Ghent, K.L. Ledeganckstraat 35 Ghent. 

Tel.       32 (9) 2645306
Fax.      32 (9) 2645279
E-mail:  [email-masked]
----------------------------------------------------

---

From: Bruno Bienfait <[email-masked]>
Date: Fri, 02 Jul 1999 16:51:04 -0400

>         Although, I receive a 'segmentation fault' message when program stops at docking parameter:

The problem you encountered seems to be quite similar to the one  I encountered on Linux (the program stops at the same
place).  The cause might be the same : insufficient stack space. I would like to suggest to make a few changes to the
source code, as I described previously on this list:

"
The readPDBQ() function allocates  multidimensional arrays on the stack. The easiest solution is to patch
the source code by changing the declaration type for these arrays. For example, the line readPDBQ.cc:82

char  record[ MAX_RECORDS ][ LINE_LEN ];

can be patched  to :

static  char  record[ MAX_RECORDS ][ LINE_LEN ];

. I have applied such a change to each local  array declaration in readPDBQ.cc.  The static keyword  tells the compiler
to allocates the local variables in the heap
(permanent storage) and not on the stack (transient storage). This is not a problem here because this function is called
only once. Also, beside crash suppression,
this  patch provides automatic initialization of the  local variable "Rec_atomnumber" in the function readPDBQ, which
otherwise would be  used unitialized (i.e. might
contain random data).

The same patch procedure should be applied to the file analysis.cc to avoid crashing during analysis.
"

Hopes this can help,

Bruno

--
[ Bruno Bienfait, Ph. D.            Laboratory of Medicinal Chemistry ]
[                                   National Cancer Institute         ]
[ Email : [email-masked]      National Institutes of Health     ]
[ Phone : (301) 402-3111            Building 37, Room 5B20            ]
[ Fax   : (301) 496-5839            Bethesda Maryland 20892 , USA     ]
[ WWW   : http://www.brunob.org                                       ]