Subject: Java molecule viewer

From: "Mackey, Mark" <[email-masked]>
Date: Wed, 07 Jul 1999 03:31:05 -0400

Hi everyone.

For various reasons I would like a Java applet for viewing molecules in 3D.
My requirements are reasonably specific, and include the ability to display
and independently rotate numerous molecules in the same window. I've looked
around, and have yet to see anything that will fit my requirements off the
shelf, so am left with the task of writing my own :). I'm not that good at
Java yet, and would prefer to avoid reinventing the wheel.

So, does anyone know if there is source code available for even a simple
molecule viewer? For portability reasons I would prefer code that works with
Java 1.1 or older: I've found a few molecule viewers (such as the
publically-released viewer from Tripos) but these all seem to require the
JDK 1.2 and Java3D extension.

All help appreciated :)

Mark Mackey.

---

From: Ferenc Csizmadia <[email-masked]>
Date: Wed, 07 Jul 1999 11:37:23 +0200

Mark,

We have a product called Marvin that contains applets for drawing and viewing
structures. (See http://www.chemaxon.com/products.html) It supports the display of
numerous structures and works with all Java versions. Our policy doesn't allow to
provide the source code, but since our company is interested in custom development,
we would be glad to develop a product that meets your expectations.

We are about to finish version 2 that has more support for 3D than the present
version. It will also work with with all Java versions (Swing is also supported).
It can be previewed at http://www.jchem.com/marvin/ . (Unfortunately the 3D example
is not yet ready, but we are working on it)

Regards, Ferenc
--
Ferenc Csizmadia, Ph.D.
Managing Director
ChemAxon Ltd.
Valyog u. 7, H-1032 Budapest, Hungary
http://www.chemaxon.com
T:+3620 9570988
Fax: +361 3875944
mailto:[email-masked]

"Mackey, Mark" wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]