Subject: G98 "writwa" again

From: "Qadir K. Timerghazin" <[email-masked]>
Date: Thu, 8 Jul 1999 23:06:49 +0500

Dear CCLers,

Some days ago I wrote:
> Using G98w I often get such error during hi-level calcualtions (MP4,
> QCISD(T), etc.):
>
> Erroneous write. write -1 instead of 50250000.
> fd = 2
> writwa
>
> What's is this? How to fix this problem?
Many people have replied me. The common answer is: "this error due to
too small disk space for scratch files". I encountered
this error many times before, and solved the problem by enlarging the disk
space.
But now, performing G2 calculation of CH3OClO I encountered "writwa"
in the beginning of QCI step:

#P Geom=AllCheck Guess=TCheck QCISD(T,E4T)/6-311G(d,p)

I had free space large enough (>4 GB) and the rwf file was 1-1.5 GB
after this crash. Then I write Tran=Conven:

#P G2 maxdisk=4250MB Tran=Conven geom=check

and QCI step passed without any problems! And the rwf file didn't exceed
2 GB! So, enigmatic "writwa" error doesn't appear only in the case of
the lack of disk space.

Later, this job produced error during
#P Geom=AllCheck Guess=TCheck MP4/6-311G(2df,p)

Could anyone explain this?

Best regards,
 Qadir Timerghazin                         mailto:[email-masked]

---

From: "Jim Kress" <[email-masked]>
Date: Thu, 8 Jul 1999 14:28:04 -0400

If you are working with G98W on an NT system there are a number of
undocumented file size limitations - some caused by NT, others caused by the
G98W programmers.

For example, with G98W you cannot have a read write file (rwf)  that is
larger than 2GB.  You may see one that appears to be larger but G98W will
crash if you continue the calculation.  If you expect your rwf will need to
be larger than 2GB you will need to use the multiple rwf option for G98W and
specify multiple rwf files that are all LE 2GB (this is an undocumented
'feature' of G98W).  Also, the maxdisk parameter cannot exceed 16GB due to
32 bit signed integer limitations in G98W.  Also, when you specify multiple
rwf files in G98W the rwf file names you use will interact with the other
file names you specify for G98W so that the more rwf you specify the fewer
characters you can use for other file names.  In the limit of specifying 8
rwf files you will have no characters left over for file names of any other
files you may want to specify in G98W.  This is another undocumented
'feature' that G98W contains.

Gaussian refuses to acknowledge these problems exist and they refuse to
provide support for their resolution even though I have sent them sample
data that conclusively demonstrates all these problems.  This is one reason
why I switched to GAMESS.

Good luck.

Jim

Check out my web site  http://www.kressworks.com/
It'll blow your mind (politically), stimulate your senses (artistically)
and provide scientific insights that boggle the mind!

----- Original Message -----
From: WeiQuan Tian <[email-masked]>
To: Max Valdez <[email-masked]>
Cc: Sigismondo Boschi <[email-masked]>; <[email-masked]>
Sent: Wednesday, July 07, 1999 2:40 PM
Subject: CCL:Erroneous write. write -1 instead of 50250000

>
>   Hi,
>
>  Maybe it is not only the problem for disk space. I did a calculation
> C26H12O with 6-31G* by BLYP. I have 2 GB disk space for scratch file and I
> am sure that this calculation doesn't need more than 2GB disk space.
> However the job stopped at l1002 for the frequency calculation. So I guess
> it is due to memory, however, I have 128MB memory in PII350 and I included
> 120MB for the calculation. I was confused with this error. As in fact I
> met the similar problem with UNIX, while I can't remember how I solved
> such a problem.
>
>  Wei Quan Tian
>  Univ. of GUelph
>  Canada
>
>
> On Wed, 7 Jul 1999, Max Valdez wrote:
>
> >     Hi everybody
> >     That kind of error is due because the disc has no more space to
write on it.
> > Make sure you will have enough space before you send that kind of
calculation (or
> > when the molecule is too large). i had the same problem a few days ago.
> >
> >     I hope this helps
> >     Waves
> >     Max
> >
> > Sigismondo Boschi wrote:
> >
> > > Hi all,
> > >
> > > I have got some similar errors with g98 (A6) on an IBM SP Power3,
> > > compiled with compiler version xlf 5.1. Is it an error due to the
> > > impossibility of writing some files, or is it a gaussian error?
> > >
> > > I'm recompiling g98 (A7) with the new compiler, in order to see it
changes
> > > something.
> > >
> > > Thanks in advance.
> > >
> > > kind regards
> > >
> > >      Sigismondo Boschi
> > >
> >
>  -------------------------- ------------------------- --------------------
> > > |                          |  http://incm.cineca.it  |
|
> > > |                           ------------ ------------
|
> > > |Sigismondo Boschi                       |tel: +39 051 6171559
|
> > > |CINECA (High Performance Systems)       |fax: +39 051 6132198
|
> > > |via Magnanelli, 6/3                     |e-mail: [email-masked]
|
> > > |40033 Casalecchio di Reno (BO)-ITALY    |
|
> >
>  --------------------------------------- ---------------------------------
> > >
> > > On Wed, 7 Jul 1999, Qadir K. Timerghazin wrote:
> > >
> > > > Dear CCLers,
> > > >
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]

----- Original Message -----
From: Qadir K. Timerghazin <[email-masked]>
To: <[email-masked]>
Sent: Thursday, July 08, 1999 2:06 PM
Subject: CCL:G98 "writwa" again

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]

---

From: Laurence Lavelle <[email-masked]>
Date: Thu, 08 Jul 1999 12:33:03 -0700

See two comments below.

At 02:28 PM 7/8/99 -0400, Jim Kress wrote:
>crash if you continue the calculation.  

Does this symptom also show up with G98W running indefinitely (CPU 100%
use) and no progress ? 

>If you expect your rwf will need to
>'feature' of G98W).  

As far as I know G98W does not allow multiple rwf files. 
If you have successfully done this I would appreciate knowing how.

>Also, the maxdisk parameter cannot exceed 16GB due to
Admins
>[email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
>Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
>
>
>
>

Laurence

""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
"""""""""""""""" 
Laurence Lavelle, Ph.D. 
University of California Los Angeles 
Department of Chemistry & Biochemistry and Molecular Biology Institute
Laboratory of Structural Biology & Molecular Medicine 
Los Angeles, CA 90095-1570, USA 

Email:[email-masked] 
Phone (Office): (310) 825-2083
Room 3048A Young Hall
Fax: (310) 206-4038  
Phone (Lab): (310) 206-8270
Room 269B MBI
http://www.doe-mbi.ucla.edu/people/lavelle/lavelle.html 
""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
""""""""""""""""

---

From: WeiQuan Tian <[email-masked]>
Date: Thu, 8 Jul 1999 15:42:26 -0400 (EDT)

It's right that G98W does not allow the splitting of rwf files both in
W9x and NT. One professor in my university called Gaussian Inc. for this
matter.

 Wei Quan Tian

---

From: "Jim Kress" <[email-masked]>
Date: Thu, 8 Jul 1999 15:56:09 -0400

Then your professor was misled.  I have done it repeatedly on my NT machine.

Here is an example:

%Mem=438MB
%rwf=K:\1\,2GB,K:\2\,2GB,K:\4\,2GB
%nosave
%chk=ne
#MP4SDTQ (FULL)/AUG-cc-pV5Z 6D 10F guess=check scf=tight

Neon dimer for MP4SDTQ and AUG-cc-pV5Z

0 1
Ne1 0. 0. 0.
Ne2 0. 0. 2.4

the output file is attached.

Also, look on page  10 of the G98W manual (manual version 6.0).

Jim