Subject: Re: CCL:Erroneous write. write -1 instead of 50250000

From: Mehnert Thomas <[email-masked]>
Date: Thu, 08 Jul 1999 11:07:48 +0200

Hi altogether!

There are several points to take into account in respect to your problems.
1) On several computer systems there were set certain limits for users especially if
many people are working on such systems because the users have to divide the available
resources. You can examine this possibility with "quota -v".
2) If you are working with NQS (Network Queuing System) you have to examine
if there are some kinds of limitations.
3) Maybe you have some limitations for one file or one job setting with the order
"limit".

Generally, the error message: "Erroneous write. write -1 instead of 50250000"
indicates a disk space problem and no memory problem. "write -1" means that the
Computer could not write to a certain file since there are some limitations or your
computer system has essentially not enough physical disk space. So your swap space of
about 2GB will be useless concerning your actual problem.
Frequency calculations and any kind of high level calculations such as QCISD or MP4
need a lot of disk space. For example your frequency calculation needs
less than 200MB memory space for every pass but your disk space requirements will be
possibly 30GB or more.
Increase your disk space or reduce your level of calculations or your basis set and
all your problems (no, of course only this problem) will disappear.

Thomas Mehnert
Tech. Univ. of Munich
Germany

> Hi,
>
>  Maybe it is not only the problem for disk space. I did a calculation
> C26H12O with 6-31G* by BLYP. I have 2 GB disk space for scratch file and I
> am sure that this calculation doesn't need more than 2GB disk space.
> However the job stopped at l1002 for the frequency calculation. So I guess
> it is due to memory, however, I have 128MB memory in PII350 and I included
> 120MB for the calculation. I was confused with this error. As in fact I
> met the similar problem with UNIX, while I can't remember how I solved
> such a problem.
>
>  Wei Quan Tian
>  Univ. of GUelph
>  Canada
>
>
> On Wed, 7 Jul 1999, Max Valdez wrote:
>
> >     Hi everybody
> >     That kind of error is due because the disc has no more space to write on it.
> > Make sure you will have enough space before you send that kind of calculation (or
> > when the molecule is too large). i had the same problem a few days ago.
> >
> >     I hope this helps
> >     Waves
> >     Max
> >
> > Sigismondo Boschi wrote:
> >
> > > Hi all,
> > >
> > > I have got some similar errors with g98 (A6) on an IBM SP Power3,
> > > compiled with compiler version xlf 5.1. Is it an error due to the
> > > impossibility of writing some files, or is it a gaussian error?
> > >
> > > I'm recompiling g98 (A7) with the new compiler, in order to see it changes
> > > something.
> > >
> > > Thanks in advance.
> > >
> > > kind regards
> > >
> > >      Sigismondo Boschi
> > >
> > >  -------------------------- ------------------------- --------------------
> > > |                          |  http://incm.cineca.it  |                    |
> > > |                           ------------ ------------                     |
> > > |Sigismondo Boschi                       |tel: +39 051 6171559            |
> > > |CINECA (High Performance Systems)       |fax: +39 051 6132198            |
> > > |via Magnanelli, 6/3                     |e-mail: [email-masked]      |
> > > |40033 Casalecchio di Reno (BO)-ITALY    |                                |
> > >  --------------------------------------- ---------------------------------
> > >
> > > On Wed, 7 Jul 1999, Qadir K. Timerghazin wrote:
> > >
> > > > Dear CCLers,
> > > >
> > > > Using G98w I often get such error during hi-level calcualtions (MP4,
> > > > QCISD(T), etc.):
> > > >
> > > > Erroneous write. write -1 instead of 50250000.
> > > > fd = 2
> > > > writwa
> > > >
> > > > What's is this? How to fix this problem?
> > > >
> > > >
> > > > Best regards,
> > > >  Qadir Timerghazin                       mailto:[email-masked]
> > > >
> > >
> >
> >
> >
> >
> >
> >
> >
>
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

---

From: "Jim Kress" <[email-masked]>
Date: Thu, 8 Jul 1999 14:27:21 -0400

If you are working with G98W on an NT system there are a number of
undocumented file size limitations - some caused by NT, others caused by the
G98W programmers.

For example, with G98W you cannot have a read write file (rwf)  that is
larger than 2GB.  You may see one that appears to be larger but G98W will
crash if you continue the calculation.  If you expect your rwf will need to
be larger than 2GB you will need to use the multiple rwf option for G98W and
specify multiple rwf files that are all LE 2GB (this is an undocumented
'feature' of G98W).  Also, the maxdisk parameter cannot exceed 16GB due to
32 bit signed integer limitations in G98W.  Also, when you specify multiple
rwf files in G98W the rwf file names you use will interact with the other
file names you specify for G98W so that the more rwf you specify the fewer
characters you can use for other file names.  In the limit of specifying 8
rwf files you will have no characters left over for file names of any other
files you may want to specify in G98W.  This is another undocumented
'feature' that G98W contains.

Gaussian refuses to acknowledge these problems exist and they refuse to
provide support for their resolution even though I have sent them sample
data that conclusively demonstrates all these problems.  This is one reason
why I switched to GAMESS.

Good luck.

Jim

Check out my web site  http://www.kressworks.com/
It'll blow your mind (politically), stimulate your senses (artistically)
and provide scientific insights that boggle the mind!