Subject: Re[2]: CCL:natural internal coordinates

From: Mike Peleah <[email-masked]>
Date: Wed, 4 Aug 1999 11:13:36 +0300

+======================---------------- --- -- -  -   -     -        .
| Dear Mike,
:
.

you wrote:

M> excuse   my   ignorance,   what   do  you  call  "natural  internal
M> coordinates"?  Are  they  - torsional angles, bond angles, and bond
M> lengths
It  is  a  combination  of  torsional  angles,  bond  angles, and bond
lengths.  This  coordinates  are  described  in  P.Pulay,  G.Fogarosi,
F.Pang,   J.E.Boggs   //  J.Am.Chem.Soc.  101,  2550-2560  (1979)  and
G.Fogarasi,   X.Zhou,   P.W.Taylor,  P.Pulay  //  J.Am.Chem.Soc.  114,
8191-8201 (1992).

These  coordinates  are  better  than  cartesian  and  Z-matrix for my
systems (multiring).

Best regards,
 Mike                            mailto:[email-masked]

                                                                     :
                                                                     |
.        -     -   -  - -- --- ----------------======================+

---

From: Mike <[email-masked]>
Date: Wed, 4 Aug 1999 22:31:18 +0000 (GMT)

> G.Fogarasi,   X.Zhou,   P.W.Taylor,  P.Pulay  //  J.Am.Chem.Soc.  114,

Well, these coordinates have been used "since day 1" in polymer
simulations (and small molecules also", given cartesian coordinates
and connectivity of the atoms (list of bonds, angles, and torsions)
calculating bond lengths should be trivial,
first: calculate the vectors for all bonds:
l=r_i-r_j, bond length - is it's length ,
angle between two
bonds is calculated from the scalar product of two bond vectors:
cos(phi) = l_i*l_(i+1)/|l_i||l_(i+1)|

torsions are a little trickier, but also not hard:
torsional angle is an angle between the planes made up by three successuve
bonds l_(i-1), l_i, l_(i+1), normals to the planes are a=[l_i x l_(i-1)]
and b=[l_(i+1) x l_i] ([ x ] - stands for the cross-product of two
vectors. Torsional angle can be determined as angle between a and b,

I hope it will not take you long to write a simple program to implement
these calculations.

More details can be found in any simulation text of which the
standard is M.P.Allen and D.J.Tildesley "Computer Simulations of liquids"
or in a series of papers from group of prof.  Ueli Suter, Doros N.
Theodorou and others from that group from 1985 and later, they are all
published in Macromolecules
>from that time.

For instance:
@incollection{Ludovice92,
	author="Ludovice,P.J. and  Suter,U.W.",
	title="Detailed Molecular Structure of a Polar Vinyl Polymer
Glass",
	booktitle="Computational Modeling of Polymers",
	editor="J.Bicerano",
	publisher="Marcel Dekker",
	address="New York",
	year="1992",
	pages="401"}

@article{The85,
        author="Theodorou, D.N. and Suter, U.W.",
        title="Detailed Molecular Structure of a Vinyl Polymer
Glass",
        journal="Macromolecules",
        year="1985",
        volume="18",
        pages="1467-1478"
}

@Book{SuterMattice,
  author = 	 {Mattice,W. and Suter,U.W.},
  ALTeditor = 	 {},
  title = 	 {Conformational theory of large molecules, the rotational
isomeric state  model in macromolecular systems},
  publisher = 	 {J.Wiley},
  year = 	 {1994},
  OPTkey = 	 {},
  OPTvolume = 	 {},
  OPTnumber = 	 {},
  OPTseries = 	 {},
  address = 	 {New York},
  OPTedition = 	 {},
  OPTmonth = 	 {},
  OPTnote = 	 {},
  OPTannote = 	 {}
}

Hope it helps
Michael

> ... Åñëè ãîëîâà áîëèò, çíà÷èò îíà åñòü                               .
>                                                                      :
>                                                                      |