Subject: bibtex

From: Bernd Engels <[email-masked]>
Date: Mon, 9 Aug 1999 09:58:05 +0200 (MES)

dear ccl'er

The following question has nothing to do with
computational chemistry but with the problem
to handle all the interesting literature citation
you get (for example from the CCL).
A very good tool is bibtex. Now I am looking
for a style-file which does the following:
1. gives the label as citation mark
2. gives the contents of an additional field named
'abstract'
3. goes through various bibtex datasets and prints
the name of the dataset as a header and then the
contents of the bibtex dataset in alphabetic ordering.

example: the bibtex-file should be 'spektros.bib'
and the first block:

@article{avnir98:jacs_0,
author   = {S. Keinan and D. Avnir},
title    = {},
journal  =  jacs,
volume   = {120},
pages    = {6152},
year     = {1998},
abstract = {Quantitative Chirality in Structure-Activity Correlations.
Shape recognition by Trypsin by the $\rm D_2$ Dopamine Receptor, and
by Cholinesterases}
}

Then the style should give:

spektros.bib:

[avnir98:jacs_0] S. Keinan and D. Avnir, J. Amer. Chem. Soc, 120, 6152 (1998):
Quantitative Chirality in Structure-Activity Correlations.
Shape recognition by Trypsin by the $\rm D_2$ Dopamine Receptor, and
by Cholinesterases

or something similar. I have some ideas to make it, but perhaps
somebody were already successful. 

If other people are interested I will summarize.

Bernd Engels
Organische Chemie
Universität Würzburg

---

From: Jochen Kuepper <[email-masked]>
Date: Mon, 9 Aug 1999 19:51:37 +0200 (CEST)

> A very good tool is bibtex. Now I am looking

Absolutely :-)

> 1. gives the label as citation mark

What do you mean - something like abbrev ?
Or do you mean similar to natbib stuff ?

Looking below I understand - that's called the key of the entry, not its
label :-) Well, so I don't know, sorry.

Have you checked the TeX-FAQ and de-TeX-FAQ ? Check out www.dante.de. If
you cannot get a solution there, ask at news:de.comp.text.tex or
news:comp.text.tex - these are more approbiate to this kind of questions.

> 2. gives the contents of an additional field named

That's what the "note" or "annote" fields are supposed to do - why does it
have to be called "abstract" ?
(note should usually be put into *.bbl, annote not !)

> somebody were already successful. 

Good for you.
I am sure people at the newsgroups will be happy to help you if you come
in with a partial solution or some ideas. But be sure you checked the FAQs
first :-)

-- Jochen
 Heinrich-Heine-Universität Düsseldorf          [email-masked]
 Institut für Physikalische Chemie I               phone ++49-211-8113681
 Universitätsstr. 26.43.02.29                      fax   ++49-211-8115195
 40225 Düsseldorf, Germany       www-public.rz.uni-duesseldorf.de/~jochen