Subject: 3D B-spline Interpolation

From: "Y Z" <[email-masked]>
Date: Wed, 11 Aug 1999 09:40:54 EDT

Dear all:

Does anyone know any references about the numerical algorithms
for the three-dimensional B spline interpolation? Are there any
FORTRAN subroutine for this method?

Your help will be highly appreciated.

Y.Z

_______________________________________________________________
Get Free Email and Do More On The Web. Visit http://www.msn.com

---

From: Richard Gillilan <[email-masked]>
Date: Thu, 12 Aug 1999 13:54:20 -0400

> FORTRAN subroutine for this method?

"A Practical Guide to Splines" by Carl de Boor 
Applied Mathematical Sciences Vol 27
Springer-Verlag 1985
(QA1.A647)

is a classic text that contains Fortran code listings. 
Perhaps practical to applied mathematicians but I find it impenetrable

A much easier book is  "The NURBS Book"
Les Piegl and Wayne Tiller Chaps 2,3
Springer, New York
QA 224 .P54x 1995

It contains short snippets of highly optimized C code that could be translated
to Fortran without too much trouble (if you must).

Beware: the B-spline formula is easy to apply incorrectly. Make sure your knot
        vectors and control points are centered on the interval containing the
        point to be evaluated.

You are also welcome to my version of the code (C++).

Richard Gillilan
Cornell Theory Center

ps. May I ask why you are interested?

---

From: "TJ O'Donnell" <[email-masked]>
Date: Thu, 12 Aug 1999 10:34:02 -0500

There is an algorithm in "Numerical Recipes"
for multi-dimensional B-spline interpolation.
The code is there too, in Fortran or C.  Take your pick.

TJ O'Donnell
[email-masked]

Y Z wrote:
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]