Subject: greek letters in html

From: "TJ O'Donnell" <[email-masked]>
Date: Thu, 14 Oct 1999 22:25:20 -0700

You can use HTML "character entities" such as
&alpha; &beta; &gamma;  and
&Alpha; &Beta; &Gamma;  etc.
Most browsers will render these properly, but it
you may have to use the <FONT> tag as well.
It is possible for users to override any
<FONT> you have specified.  There is no
way to absolutely guarantee the greek letters
(or any character, actually) will be rendered
as you intended it.

As for a reference, I find the O'Reilly books
excellent, for example "Dynamic HTML" by
Danny Goodman has a table of character
entities on page 1018.

Try this link as well.
http://www.w3.org/MarkUp/html3/mathsym.html

TJ O'Donnell
[email-masked]

On Fri, 15 Oct 1999, Kieran F Lim (Lim Pak Kwan) wrote:

> How can I put greek letters into a HTML page?
> Can someone please point me to a reference/help site?

---

From: "Jesus M. Castagnetto" <[email-masked]>
Date: Fri, 15 Oct 1999 03:15:12 -0700 (PDT)

Appart from the spec docs at the W3C site (http://www.w3c.org/), one of the
best sites for HTML help is: http://www.htmlhelp.org/

There you will see that the HTML 4.0 specs call for Greek entities in the DTD
(Document Type Definition), but as most know, the recent browsers only
implement the transitional DTD, so some entities are not supported. The way to
assure that the greek letter will show up as such is to use inline images,
this avoids the problem of assuming that the person viewing the page has the
"Symbol" font installed, and also avoids using the (now) deprecated <FONT>
tag.

In the web site mentioned above, there is a link to a collections of glyphs
>from the Unicode organization:

  http://charts.unicode.org/Unicode.charts/normal/Unicode.html

And the images for the Greek set are at the URL:

  http://charts.unicode.org/Unicode.charts/normal/U0370.html

Hope this helps.

--
Jesus M. Castagnetto <[email-masked]> - "Ken Zen Ichi-nyo"
Program Project:   http://www.scripps.edu/research/metallo/ 
Metalloprotein DB: http://metallo.scripps.edu/
Pilot Stuff: http://www.geocities.com/ResearchTriangle/Lab/1059/