Subject: Rendering molecules

From: Simon Hogg <[email-masked]>
Date: Tue, 07 Dec 1999 17:06:47 +0000

I am making a movie of an MD time step by the following method;

run dynamic trajectory in Tinker --> output 1000 xyz (tinker) files
run xyzpdb as a batch job to convert xyz --> output 1000 pdb files

Then I was going to use either molpov or povchem to convert to pov scenes, 
then render them overnight, but I just found out that those two packages 
don't do batch jobs (at least as far as I can see)  so I went hunting for 
pdb2pov, but that doesn't like my pdb files (one is attached below - it 
should be glycerol).  The message it returns is 'no atoms'.  Can anyone 
help with either recommending a batch converter or another *freeware* program?

HEADER    Default title for: Tinker
COMPND
SOURCE
HETATM    1  C     1     1      -0.058  -1.170  -0.063
HETATM    2  C     1     1      -0.158   0.374  -0.320
HETATM    3  C     1     1      -1.608   0.713  -0.401
HETATM    4  O     6     1       0.593   0.984   0.672
HETATM    5  H     5     1       0.920  -1.619  -0.291
HETATM    6  H     5     1      -0.307  -1.376   1.005
HETATM    7  H     5     1      -0.747  -1.601  -0.738
HETATM    8  H     5     1       0.272   0.698  -1.301
HETATM    9  H     5     1      -1.722   1.828  -0.380
HETATM   10  H     5     1      -2.293   0.456  -1.275
HETATM   11  H     5     1      -2.143   0.238   0.509
HETATM   12  H    21     1       0.073   1.554   1.149
CONECT    1    2    5    6    7
CONECT    2    1    3    4    8
CONECT    3    2    9   10   11
CONECT    4    2   12
CONECT    5    1
CONECT    6    1
CONECT    7    1
CONECT    8    2
CONECT    9    3
CONECT   10    3
CONECT   11    3
CONECT   12    4
END

---

From: Rick Venable <[email-masked]>
Date: Tue, 7 Dec 1999 14:37:47 -0500 (EST)

I found that pdb2pov doesn't recognize HETATM records; change them to
ATOM records and it should work okay.  You can automate the change via
awk or sed.

I also found that pdb2pov creates a large POV union object for the whole
molecule; povray3 will render the scene a lot faster if you remove the
union.  I've hacked pdb2pov to make a version that creates .pov files
more suited to povray3.  Again, this change to the .pov file could also
be automated via sed or awk.

On Tue, 7 Dec 1999, Simon Hogg wrote:
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 
> 

Rick Venable                  =====\     |=|    "Eschew Obfuscation"
FDA/CBER Biophysics Lab       |____/     |=|
Bethesda, MD  U.S.A.          |   \    / |=|  ( Not an official statement or
[email-masked]          |    \  /  |=|    position of the FDA; for that,
http://www.erols.com/rvenable       \/   |=|    see   http://www.fda.gov  )