Subject: Re: CCL:column editor

From: Iraj Daizadeh <[email-masked]>
Date: Fri, 10 Dec 1999 16:57:12 -0500 (EST)

Emacs...fine...

For a nicer interface try the freeware product:
	
	nedit

latent on sgi....to pick out columns use the 

	control-mouse (index1 for righthanders)...

iraj.

> For simple things the good old emacs has colum functions:
>    M-x kill-rectangle         
>    M-x yank-rectangle
> You mark the rectangular region (from mark to current cursor), kill it,
> (i.e., cut it out), move the cursor where you want it placed
> and yank it. Of course, you can kill it, and not yank it, if you only
> want to delete text.
> 
> Jan
> 
> Jan K. Labanowski            |    phone: 614-292-9279,  FAX: 614-292-7168
> Ohio Supercomputer Center    |    Internet: [email-masked] 
> 1224 Kinnear Rd,             |    http://www.ccl.net/chemistry.html
> Columbus, OH 43212-1163      |    http://www.ccl.net/
> 
> n Fri, 10 Dec 1999, Iraj Daizadeh wrote:
> 
> > 
> > Interesting query...
> > 
> > For multiple alignments editors require in a most direct way your
> > interests...please check the following--for example...
> > 
> > http://www.ibcp.fr/mpsa
> > 
> > First transform your data into the following form:
> > 
> > >
> > 150109492812
> > >
> > 10328283823
> > >
> > 39183923023043
> > 
> > or 
> > 
> > >
> > agtctgtctttct
> > >
> > agcttttcttctc
> > 
> > I am only guessing that it can perform the same column functions with
> > numbers as well...--doubt it in retrospect....this is not excel....
> > 
> > please summarize--ricardo.....
> > 
> > iraj.
> > 
> > Iraj Daizadeh, Ph.D.
> > Harvard University
> > Department of Cellular and Molecular Biology
> > The Biological Laboratories
> > 16 Divinity Avenue
> > Cambridge, MA 02138
> > Phone:   (617) 495-0783
> >          (617) 495-0560
> > Fax:     (617) 496-4313
> > Email:   [email-masked]
> > WebPage: http://mcb.harvard.edu/gilbert/daizadeh
> > 
> > 
> > On Fri, 10 Dec 1999, Ricardo Grau Crespo wrote:
> > 
> > > Hi CCL,
> > >  Could you please tell if there is any editor for Linux that allows
> > > working (inserting, deleting, moving, etc) with data columns. And, if
> > > yes, where can I find it?
> > >  Excuse me if this is not strictly a computational chemistry question,
> > > but I need to know that for working with input and output files of my
> > > calculations.
> > >  Thank you very much in advance,
> > > Ricardo.
> > > 
> > > -- 
> > > **************************************************************
> > > * Ricardo Grau Crespo <[email-masked]>                 *
> > > * Catalysis Department, Center for Petroleum Research.       *
> > > * Washington # 169. Cerro, Havana,  CUBA                     *
> > > **************************************************************
> > > 
> > 
> 
>

---

From: Iraj Daizadeh <[email-masked]>
Date: Sat, 11 Dec 1999 12:12:43 -0500 (EST)

This is indeed a fantastic finding....Thanks iraj...

> In your linux distribution :-). Linux's vi is in fact a link to vim - an
> improved version of vi. In vim selecting of a column may be done with
> cursor arrows after ctrl-v combination. Then deleting with 'd' and so on
> (as always - man vi).
> 
> Przemek G. Czyryca 
> Utah State University
> 
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 
>