Subject: Re: Anybody agrees with me?

From: Alain Dietrich <[email-masked]>
Date: Thu, 10 Feb 2000 11:13:26 +0100 (MET)

I sincerely admire Renxia (aka Arthur) for its
outstanding development effort of LigBuilder
during his PhD.

I profoundly regret the content of this "claim
for unifying". Its either a deliberate provocation
or the guy is more than naive and/or has no conscience
of what History is, and how things come to birth.

Anyway, the MacroModel package is "our" best in
best and we still heavily use and rely on it here.
Hope that we'll have the freedom to continue to play
with it for a while, without asking Bill's advice.

-AD

______________________________________________________________

Novartis Pharma AG    Email [email-masked]
Alain Dietrich        Tel                     +41 61 696 68 46
WKL-136.P.69          Fax                     +41 61 696 27 61
CH-4002 Basel         Web              http://www.novartis.com
Switzerland
______________________________________________________________

---

From: Peter Shenkin <[email-masked]>
Date: Thu, 10 Feb 2000 11:46:00 -0500 (EST)

Hi,

This is a bit long-winded, so be warned. :-)  I want
to point out some of the issues that make it hard to
define a single "best" paradigm for GUI design, and
also to make some remarks about MacroModel and our
new Maestro interface.

First, Alain, thanks for your kind words concerning
MacroModel.

I think Renxia's remark concerning "why don't we have
a standard" for how these programs work is, in fact,
somewhat naive, for the reasons Alain pointed out.

I also don't think it's that hard to learn the basic
operations of a new GUI (in my experience, anyway).
For the complex operations, the underlying model
and capabilities of GUIs differ greatly enough so that
I doubt there's enough in common to standardize.

We see this even in desktop design, spreadsheets and 
word-processing programs, so perhaps it's not too 
surprising that we see it in comp. chem. GUIs as well.

I greatly admire the user-friendliness of Spartan, which
Renxia pointed out.  This comes, in part, because it is 
quite deliberately spartan -- hence the name.  It doesn't 
try to do everything.  

In fact, our awareness of the need for a simple interface to 
do the basics led to our partnership with Wavefunction that 
resulted in the Titan product.

But in fact, my experience is that "versatility is the
enemy of comprehensibility."  The more an interface can
do, the more difficult it is to make it user friendly.

Professional modelers need to do very complicated
things, indeed, and it is tough to find a model that
is conceptually simple yet extensible enough to 
allow new things to be implemented that will only be 
dreamed up tomorrow.

It might be that in 20 years, we'll know enough about the
human mind and about how to organize not only data
(nouns) but transformations (verbs) that a grand,
unified user-interface paradigm will have emerged.  In
the meantime, we're all groping toward being as 
user-friendly as possible, while being as general as 
necessary.

As Alain's remarks point out, there are lots of MacroModel 
users out there who know the MacroModel interface well 
and love it.  Once you learn it, it is often easier to do 
complicated things with it than it is to do these things with 
other programs. 

Nevertheless, several years ago we recognized that our 
MacroModel interface (whose design dates back to VAX/VMS
days) is not as user-friendly as it could be.  We decided
to develop a new interface, now called Maestro, which 
is being distributed right now as sort of a bare-bones preview
along with MacroModel in our 7.0 distribution.  For
the 7.5 release, late this year, we hope to fill Maestro out 
sufficiently that we can retire the old MacroModel GUI.

Our goals in developing Maestro were derived at least in
part from many user requests we've had over the years.

	1.  Make the invisible visible:  make the interface
	    as self-docuemnting as possible.  All options
	    and settings should be visible or easily made
	    visible.

	2.  Give it a look and feel more like contemporary
	    GUIs, but don't give existing users something
	    that's totally strange to them.  Obviously,
	    this is a narrow path to tread.  We did go through
	    a few prototypes and have them evaluated by
	    exisiting users, as well as new users, in order
	    to guide us.

	3.  Make it scriptable.

	4.  Many smaller points:  use OpenGL, build an
	    architecture that's easy to extend, etc.

We will be interested in hearing back from people who have
tried Maestro.  Hopefully, both the Renxias and the Alains 
of the world will find more to like than to dislike, but
whatever your impressions are, we'd like to hear your
thoughts and suggestions.

	-P.

On Thu, 10 Feb 2000, Alain Dietrich wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 

--
** Whether the playing field is level depends on the coordinate system. ***
********* Peter S. Shenkin; Schrodinger, Inc.; (201)433-2014 x111 *********
*********** [email-masked]; http://www.schrodinger.com ***********