Subject: Three dimensional FFT

From: "Y Z" <[email-masked]>
Date: Sun, 20 Feb 2000 02:18:53 EST

Hi,

Are there any way to calculate a (256,256,256) order
DOUBLE COMPLEX FFT in FORTRAN77? I tried to do the
following subrouitine but cannot pass the compiling.

By f77 in SGI :

Warning: Stack frame size (270015328) larger than system limit (67108864)

+++++++++++++++++++++++++++++++++

      program test
      IMPLICIT DOUBLE PRECISION (A-H,O-Z)
      DOUBLE COMPLEX AA(256,256,256)
      DIMENSION ID(64),CC(64)
      DIMENSION NORD(3)
      DO 100 i=1,256
       DO 100 j=1,256
         DO 100 k=1,256
           xx=DBLE(I+j+k)
           AA(i,j,k)=DCMPLX(xx,0.0D0)
100   CONTINUE
      NORD(1)=8
      NORD(2)=8
      NORD(3)=8
      IERR=0
      CALL DFFT3D(dta,NORD,ID,CC,1,IERR)
      STOP
      END

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: Niri Govind <[email-masked]>
Date: Sun, 20 Feb 2000 11:38:57 -0800 (PST)

hi, 

  there are very good 3d-fft routines as part of the
  libcomplib.sgimath libraries on the sgis. you can get 
  information on how to use them by looking at the man pages.

  you will need to link to this library when you compile your
  program...

  try man fft, this should give you all the info you need.
  hope this helps

 cheers
 -niri
_______________________________________________________________________
Niranjan Govind, Ph.D                     Tel (Work): 310-206-5104
University of California                  Fax (Work): 310-206-4038
Los Angeles, CA 90095-1569                Email: [email-masked]
                                                 [email-masked]
_______________________________________________________________________

On Sun, 20 Feb 2000, Y Z wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 
>