Subject: CCL:The "birth-year" of computational chemistry?

From: Ernest Chamot <[email-masked]>
Date: Mon, 28 Feb 2000 00:42:07 -0600

This discussion has been interesting because, as Dominic Ryan pointed out:

>. . . .  It depends of course on just
>what you call computational chemistry.

Use of the term to mean: the ability to describe a chemical or chemical process mathematically (Theoretical Chemistry?  Pople's & Ryan's point of view?), vs. actually carrying out the necessary computation (Calculational Chemistry?)  The use of computers by chemists (analyzing data, etc.; Computers in Chemistry?) vs. modeling a chemical or chemical process with the computer (Molecular Modeling?).  Use of "Computer" in the original, more general sense (a machine that returns a numerical result; Marchesa's point of view?), vs. a more modern meaning (understood to refer to electronic, digital computers?)  Etc.

IMHO, what makes Computational Chemistry distinct, is that our chemical theories have been implemented in software, and computer hardware has developed that can run that software, to the point that it is practical to routinely APPLY theory to accurately model molecular structure and chemical processes, and to calculate numerical results which were previously only available experimentally.  So from that point of view, the "Birth" of Computational Chemistry must be when these theories _started_ being converted into software and run on the type of computer hardware that _ultimately_ became fast enough to _routinely_ model chemistry.  So I think Lingran's second question comes close to defining the birth:  

>2. Who wrote the first quantum chemistry program?

The only thing I would add, is that since only electronic, digital computers have been developed to be programmable and fast enough to routinely do these calculations, I would say the birth year is the year that someone first coded and ran a quantum chemistry (or other molecular modeling) program on an electronic, digital computer.  The worlds first electronic, digital computer, ENIAC (Electronic Numeric Integrating Automatic Computer), was constructed at the University of Pennsylvania in 1945, this sets an early limit for the birth of Computational Chemistry.

With this point of view in mind, I have some inside information (albeit second-hand) about the early days, that is relevant.  I have a close relationship with one of the programming pioneers at Argonne National Laboratories.  Cynthia Chamot (yes, this is my Mother, and I'm quite proud of her) was one of the early programmers hired by Argonne to program the third, all electronic, digital computer ever built, AVIDAC. AVIDAC (Argonne's Version of the Institute's Digital Automatic Computer) was constructed around 1950, only 5 years after ENIAC.  (Argonne's second computer, by the way, was named "George.")

She recalls working as part of a team with  several others (including Ruth Freshour & Gerry Duffy) in the Applied Math Division, to develop code for John Weil in the Chemistry Division, by 1956.  She specifically remembers the need for part of the code to find eigenvalues and invert 13x13 matrices with only 512 "words" (not K) of memory to work in!  She isn't sure whether this was a QM calculation, but it looks like Computational Chemistry had started at Argonne sometime between 1950 and 1956.

Prior to that, the military used computers on the Atomic Bomb project, as  Richard Gillian mentioned:

>I seem to recall, that Monte Carlo methods invented during the 
>Atom Bomb project in the 40's may have been the first electronic 
>computer calculations on condensed matter, although they may not qualify as
>chemistry. I remember a facinating talk by W. Wood (Los Alamos) at a computer

I know one of the earliest uses was to analyze the probability of one nuclear reaction triggering multiple nuclear reactions, to determine exactly what constituted a critical mass.  Is this the 'Monte Carlo" calculation referred to in Gillian's reference?  If so, I would consider this a Computational Physics or statistical computation rather than Computational Chemistry.  If it really is a Chemistry code, then the birth of Computational Chemistry may be before 1950: as early as 1945.

EC
---

Ernest Chamot
Chamot Laboratories, Inc.
530 E. Hillside Rd.
Naperville, Illinois 60540
(630)637-1559
[email-masked]
http://www.chamotlabs.com/cl

---

From: Harald Svedung <[email-masked]>
Date: Mon, 28 Feb 2000 12:05:50 +0100 (MET)

Hi all!

Ernest Chamot writes about some trial definitions on some cc-related 
terms.

Maby it's a little unfortunate that the term Molecular Modeling has 
become limited to the use of computers as the term says nothing about 
using any means of numerical descriptions what so ever. Yes, numerical 
meassures are practical to use, and digital, even electronic, computers 
are what we often think of in terms of tools, but the spring-and-ball 
contraption is, allthough a rugh and classical one, a modell of a 
molecular system and to handel it is therefore to do Molecular 
Modeling.

There is of course Computational Molecular Modeling with the 
'Computational' being implicit.

;-)
/Harald

Harald Svedung (Ph.Lic.)                phone:          +46-31-7722816
Department of Chemistry                 fax:            +46-31-167194
Physical Chemistry                      home phone:     +46-31-240897, +46-709223206	
Goeteborg University                    home e-mail:    [email-masked]
SE-412 96 Goeteborg, Sweden             www.che.chalmers.se/~svedung/

---

From: Jörg Grunenberg <[email-masked]>
Date: Mon, 28 Feb 2000 09:40:13 +0000

Ernest Chamot wrote:

>
>  The worlds first electronic, digital computer, ENIAC (Electronic Numeric Integrating Automatic Computer), was constructed at the University of Pennsylvania in 1945, this sets an early limit for the birth of Computational Chemistry.
>

Dear Ernest Chamot

maybe the ENIAC was the first computer in the world.

The first computer in europe, Z3 (Zuse 3) was finished by Konrad Zuse in 1941 (Berlin, Germany).

J. G.

--
Jörg Grunenberg, Org. Chemie, Hagenring 30, 38106 Braunschweig
email: [email-masked] phone: +49 531 391 5252
URL: http://www.tu-bs.de/institute/org-chem/grunenberg/grunenberg.html

---

From: "Rzepa, Henry" <[email-masked]>
Date: Mon, 28 Feb 2000 14:15:42 +0000

>.. The worlds first electronic, digital computer, ENIAC (Electronic Numeric Integrating Automatic Computer), was constructed at the University of Pennsylvania in 1945, this sets an early limit for the birth of Computational Chemistry.

A rather US centric claim.  There was certainly a computer built by Turing well before  1945
at Bletchley park, to decode the  German  Enigma ciphers which probably qualifies. Turing
was also associated with Manchester  University, that I believe also has a prior claim  to
ENIAC.  No doubt reference to the textbooks (mine are at home and  I write this from work)
will clarify this issue.

Apologies for being slightly off topic!
-- 

Henry Rzepa. +44 (0)20 7594 5774 (Office) +44 (0)20 7594 5804 (Fax)
Dept. Chemistry, Imperial College, London, SW7  2AY, UK. 
http://www.ch.ic.ac.uk/rzepa/

---

From: "David E. Bernholdt" <[email-masked]>
Date: Mon, 28 Feb 2000 11:10:56 -0500

I don't want to enter this fray except to say that one must be careful
to distinguish betweeen (a) analog and digital computers, and (b)
purpose-specific and general programmable computers.  Many early
computers were hardwired for specific tasks. I think you're free to
argue as much about the definition of the earliest computer as you are
about what constituted computational chemistry :-)

Incidentally, I know that Iowa State U claims that that the
Atanasoff-Berry Computer (built 1937-1942) was the first _digital_
computer, predating ENIAC. (http://www.scl.ameslab.gov/ABC/ABC.html)

--
David E. Bernholdt                      | Email:  [email-masked]
Northeast Parallel Architectures Center | Phone:  +1 315 443 3857
111 College Place, Syracuse University  | Fax:    +1 315 443 1973
Syracuse, NY 13244-4100                 | URL:    http://www.npac.syr.edu

---

From: Lingran Chen <[email-masked]>
Date: Mon, 28 Feb 2000 09:08:26 -0800

If you are interested in the History of Computer, 
you may check the following web site.

http://ox.compsoc.net/~swhite/timeline.html

However, please be warned that some dates
may not be absolutely correct!
-Lingran

David E. Bernholdt wrote:
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

---

From: "Luke A. Burke" <[email-masked]>
Date: Mon, 28 Feb 2000 16:26:08 -0500

Ernest Chamot wrote:
> Use of the term to mean: the ability to describe a chemical or chemical process mathematically (Theoretical Chemistry?  Pople's & Ryan's point of view?), vs. actually carrying out the necessary computation (Calculational 
...

Yes, very much so, but I think there was a definite point at which
Quantum Chemistry broke off from Quantum Mechanics. Almost all of us
quantum chemists start our calculations with not just RHF or UHF but the
LCAO-MO method. This is in the domain of linear algebra whereas much of
what went before was  differential equations. Linear algebra solutions
are the stuff of computer calculations and they were just right for the
vacuum tube computers as they are now for chips. These linear
combinations were probably what Ernest Chamot's mother was programming.
The two people who, independently, are responsible for the LCAO-MO
method being put on a firm theoretical foundation are C.C.J.Roothaan
(Rev.Mod.Phys.23,69,1951), G.G.Hall (Proc. Roy. Soc. A205, 541, 1951).
When we were publishing in the 1970's we were still calling it the
'Roothaan-Hall' LCAO-MO method.
and BTW for my younger American colleagues: it is not pronounced
"Ruth-Ann".
Luke
-- 
Luke A. Burke		
Professor and Chair, Department of Chemistry
Rutgers University, Camden, NJ08102, USA
tel: 609-225-6158/6142;fax:-6506