Subject: mount zip/cdrom on linux?

From: "Xianofeng . Duan MLBP CON" <[email-masked]>
Date: Tue, 29 Feb 2000 13:31:04 -0500 (EST)

Dear CCLers:
   We set up a linux to run G98. Frequently we need to trasfer input and 
output files to zip disks. Since only root user has privilege to 
mount/unmount zip/cdrom, now the question is: Are there are any ways for 
a general user to do so without login to the root account? 
I asked the same question on a linux forum, but so far there are no answers.

   Thanks!

****************************************
Xiaofeng Duan, Ph.D.
AFRL/MLBP, Bldg. 654
2941 P St. Ste. 1
Wright-Patterson AFB, OH 45433
****************************************

---

From: Matt Challacombe <[email-masked]>
Date: Tue, 29 Feb 2000 12:27:43 -0700

Hi Xianofeng,
In your /etc/fstab include a line like this:
/dev/sdb1  /zip ext2    noauto,user     0 0 
The user option allows the user to mount the disk.
See the mount man page as well.
-Matt
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
+ Matt Challacombe, Ph.D.           http://www.t12.lanl.gov/~mchalla/ +
+ Los Alamos National Laboratory    email: [email-masked]       +
+ Theoretical Division              vmail:   (505) 698-4112           +
+ Group T-12, Mail Stop B268        phone:   (505) 665-5905           +
+ Los Alamos, New Mexico  87545     fax:     (505) 665-3909           +
+                                                                     +
+ "The secret to mountain biking is pretty simple. The slower you go  +
+  the more likely it is you'll crash." -- Julie Furtado              +
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+   
                                                              
On Tue, 29 Feb 2000, Xianofeng . Duan MLBP CON wrote:
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

---

From: [email-masked]
Date: Tue, 29 Feb 2000 12:56:45 -0800

>I asked the same question on a linux forum, but so far there are no answers.

I believe that you can add "users" and perhaps "auto" to the options part
of the appropriate line in /etc/fstab.  I'm uncertain, but the users might
also have to be added to a certain group (disk or other?). 

I believe that "man fstab" may provide more information on this.

Kenward
----------------------------------------------------
                                          .'^~;,_
Dr. Kenward Vaughan                       ':,'~~~~~
Professor of Chemistry                    \;:/
Bakersfield College                       |,;|
Bakersfield, CA  93305                   / ', \
661-395-4243                            / o  O \
[email-masked]                   (oOoOOoOo)
                                     ---========---
                                      ???$$MM$$???
----------------------------------------------------

---

From: Jarrod Smith <[email-masked]>
Date: Tue, 29 Feb 2000 17:03:15 -0600

>a general user to do so without login to the root account? 

There is a GUI solution to this problem for your Zip drive:

http://www.scripps.edu/~jsmith/jazip

-- 
Jarrod A. Smith, Ph.D.
Assistant Director, Center for Structural Biology
Molecular Graphics and Computation
[email-masked]