Subject: Mulliken PA of MOs: Answers

From: Marketa Ludmila Munzarova <[email-masked]>
Date: Wed, 5 Jul 2000 20:50:00 +0200 (CEST)

Hi CCLers,

I am collecting here the answers which I got on
my following question:

*********************************************************************
Dear computational chemists,

I am interested in analyzing the composition of optimized
molecular orbitals from a Gaussian98 output. The MO coefficients
can be found easily, but I would like to perform a Mulliken
population analysis ot the optimized MOs.
However, the IOPs in link 601 do offer only Mulliken analysis of the
_total_ electron density. It seems to me that the only possibility
to get MOs analyzed is to code the Mulliken analysis myself,
using optimized MO coefficients and the overlap matrix.
But maybe there is still an IOP option in the Gaussian which does
this automatically?

       Thank you in advance for your help,  Marketa

---------
Marketa Ludmila Munzarova
Faculty of Science, Masaryk University Brno
e-mail: [email-masked]
--------
*********************************************************************

ANSWER1:

*********************************************************************
Return-Path: <[email-masked]>
X-Sender: [email-masked]
Date: Wed, 05 Jul 2000 09:24:38 -0300
To: Marketa Ludmilla Munzarova <[email-masked]>
Subject: Re: CCL:Mulliken pop. analysis of MOs

        Dear Ludmilla,

                I wrote a small set of subroutines to make the part of the MPA that g98
doesn't make. You have to request g98 to print the overlap matrix and the
coeffs of the MO-LCAO expansion and prepare two files from them. 
                During runtime you must answer some trivial question (# of atoms, #of
basis, ie order of the matrix, and # of MOs in which you are interested.
That's because I didn't include any parser in my routines). 
                It works well, it gives the MO population in terms of the AOs and in
terms of the atoms. This info complements well the overlap population part
that g98 does.
                If you are interested in that program please let me know and I'll send it
to you as soon as I make some changes (Titles are in Spanish!!) an include
a well-documented example.
                Regards,

                                                Reinaldo   
*********************************************************************

ANSWER2:
*********************************************************************
Return-Path: <[email-masked]>
Date: Thu, 6 Jul 2000 00:05:20 +0930
To: Marketa Ludmilla Munzarova <[email-masked]>
Subject: Re: CCL:Mulliken pop. analysis of MOs
Return-Receipt-To: [email-masked]

Hi,

Do you mean you want to do a Mulliken analysis of each occupied orbital?

That is - for MO i define P(k,l,i) = 2*C(k,i)*C(l,i)*S(k,l)
and then take sum over k of P(k,l,i) to give g(l,i) and then perhaps 
to sum g(l,i) over all orbitals l on atom A.

I coded this myself - I think it is l601. I may be able to let you have
this but I am not at home in Australia at present. I am in England. My code 
also sum the g(l,i) terms over all orbitals of the same angular momentum
quantum number as I am looking for mixing in so called core orbitals between
say d orbitals on one atom and s orbitals on a neighbour.

Regards, Brian. 

-- 
        Associate Professor Brian Salter-Duke (Brian Duke)
Chemistry, Faculty of Science, IT and Education, Northern Territory University,
          Darwin, NT 0909, Australia.  Phone (61) (0)8-89466702
e-mail: [email-masked]  or [email-masked]

******************************************************************

---

From: "S.I.Gorelsky" <[email-masked]>
Date: Wed, 5 Jul 2000 18:17:37 -0400 (EDT)

I would like to mention my program (MOMIX) which does exactly what
you want. It includes Mulliken population analysis (MPA), modified
Mulliken population analysis (MMPA) (where the overlap is scaled - the
method proposed by Stout and Politzer), and one more...

It reads output files from Gaussian 98, HyperChem, e.t.c.

The program is written as a MS-DOS or Windows application, and it is made
as user-friendly as possible (at least, I think so :-) ).
Sorry no UNIX version.  

Check the web site:

http://www.chem.yorku.ca/grad/SG/momix.htm

-----------------------------------------------------------------------

Serge

On Wed, 5 Jul 2000, Marketa Ludmila Munzarova wrote:

> Date: Wed, 5 Jul 2000 20:50:00 +0200 (CEST)
> From: Marketa Ludmila Munzarova <[email-masked]>
> To: [email-masked]
> Subject: CCL:Mulliken PA of MOs: Answers
> 
> Hi CCLers,
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 

________________________________________________________________  

  Sergey Gorelsky, M. Sc.                   
         Department of Chemistry, York University                        
         4700 Keele St., Toronto, Ontario M3J 1P3, Canada            
         tel.(416) 736-2100 ext#77720 and ext#70131
         fax:(416) 736-5936   
  http://www.chem.yorku.ca/grad/SG/                                   
________________________________________________________________