Subject: question about compiling FORTRAN codes under LINUX and SGI

From: Li Guo Hui <[email-masked]>
Date: Tue, 18 Jul 2000 10:17:4 -0800

Dear Netters:
I had compiled FORTRAN codes under linux with g77 and SGI with f77, but it gave me the following warning 
under linux:

x.f: In subroutine 'x':
x.f:126: warning:
   call b(s, ij, it, bb)
   1
x.f: b1:  call b(o1, o2, it, bb)
   2
Argument #1 of 'B' is one type at(2) but is some other type at (1) [info -f g77 M GLOBALS]

But under SGI with f77, it is compiled without any warning and error.
Could you tell me the reason?
I hope someone can help me do it correctly.
thank you very much!!!

---

From: Marcel Swart <[email-masked]>
Date: Tue, 18 Jul 2000 08:25:30 +0200

>I hope someone can help me do it correctly.

This means probably that you have not declared either s or o1 explicitly,
and f77 at SGI takes the default for this (real), while this default 
does not seem to be present with g77, or is different from the 
explicit declaration of either s or o1.

-- 
------------------------------------------------
drs. Marcel Swart

Theoretical Chemistry (MSC)
Molecular Dynamics (GBB)

Rijksuniversiteit Groningen
Chemistry Department
Nijenborgh 4
9747 AG Groningen
The Netherlands

tel : +31 - (0)50 - 3634377
fax : +31 - (0)50 - 3634441

E-mail : [email-masked]
WWW: http://theochem.chem.rug.nl/~marcel/
------------------------------------------------