Subject: Re: CCL:Imagining Software

From: Richard Gillilan <[email-masked]>
Date: Fri, 18 Aug 2000 09:26:46 -0400

Douglas_Stack/CAS/UNO/[email-masked] wrote:

> Does anyone know of a software package (Windows based preferably) that can that
> a graphic file that represents 3-D on a 2-D image (color coded contour for
> example) and generate a 2-D, graph of that data a certain point.   This would
> involve drawing a line across the picture and the program generating an x vs. y
> graph for the data points on that line.  If I could find a program that could
> convert a color-coded .tiff into x,y,z coordinates, I could import the data to
> Excel and accomplish the same thing.  What is desired is to generate x vs. y.
> graphs from a "3-D" picture (represented as a color coded .tiff image) by
> selecting different segments of the .tiff image.
>

OpenDX (www.opendx.org) can do this kind of thing. If you read the tiff in
with ReadImage, it will actaully reside within the data model as a regular grid
with a colors component. If you Mark colors as data, you can then interpolate the
data
onto any arbitrary line via Map, or select out a row or column of pixels and send
it
to the Plot module. Plot is not as fancy or full-featured as some other 2D plot
programs, but
it will do the trick. You could also simple use OpenDX to convert your data and
write
it out. As always, OpenDX takes some time to learn (just like learning a scripting
language) ... it is free.

  Richard Gillilan
  Cornell Theory Center

---

From: andre mauricio de oliveira <[email-masked]>
Date: Fri, 18 Aug 2000 15:14:08 -0300 (BSC)

Dear Dr Stack,
Maybe MatLab and Origin 5.0 are able to pursue this task.
Greets.

On Thu, 17 Aug 2000 Douglas_Stack/CAS/UNO/[email-masked] wrote:

> Thanks in advance,
> Douglas E. Stack
> Assistant Professor
> Department of Chemistry
> University of Nebraska at Omaha
> Omaha, NE 68182-0109
> (402) 554-3647
> (402) 554-3888 (fax)
> [email-masked]
> 
> 
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 
> 

Andre Mauricio de Oliveira

VOICE +55-031-374-1325
      +55-031-499-5765 
FAX   +55-031-499-5700
 
Laboratorio de QSAR e Modelagem Molecular
Nucleo de Estudos em Quimica Medicinal (NEQUIM)
NEQUIM's Homepage: http://www.qui.ufmg.br/~nequim
Departamento de Quimica ICEx
Federal University of Minas Gerais
Av Antonio Carlos 6627 Pampulha ZIP CODE 31270-901
Belo Horizonte MG Brazil