Subject: Re: SUMMARY: How to rotate a PostScript file?

From: "C.F. Matta" <[email-masked]>
Date: Fri, 25 Aug 2000 10:44:45 -0400 (EDT)

Ups, forgot one more response..sorry about that:

Response 10: Leif Norskov
=========================
I think Corel Draw should be able to do it - but not for free.
(check http://www.corel.com/)

/Leif Norskov
 Novo Nordisk A/S
 [email-masked]

___________________________________________________________________________

  Cherif F. Matta		    	  tel. (905) 525-9140 ext. 22502
  Chemistry Department                    fax  (905) 522-2509
  McMaster University                               _______________________ 
  Hamilton, Ontario, CANADA L8S 4M1.                | "Choice not chance
....................................................|  determines one's  
 Member of the Board of Governors of the University |  destiny". Anonymous 
___________________________________________________________________________

---

From: Eric Bittner <[email-masked]>
Date: Fri, 25 Aug 2000 10:26:01 -0500

on 8/25/00 9:44 AM, C.F. Matta at [email-masked] wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody    |   [email-masked] -- To
> Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 

Hi, 

two free ways that work:
 you can rotate a PS file by simply editing it. It takes a bit of
trial and error and you sort of have to know what to look for.

use  the graphics package in Latex to write a wrapper that loads the file,
rotates it creates a dvi file with the new figure.  This is really easy.

As a last + costly method
convert them to PDF (using acrobat distiller) and then edit the pdf
file using adobe illustrator.

-Cheers!
ERB

-- 
Prof. Eric R. Bittner
Department of Chemistry
Univ. of Houston
http://eiger.chem.uh.edu/bittner/

---

From: "C.F. Matta" <[email-masked]>
Date: Fri, 25 Aug 2000 10:22:33 -0400 (EDT)

Hello,

I would like to thank all those who kindly responded to my question: 
         "how to rotate a postscript file": 
Rajendra Zope, Thomas Heine, Antonio Buljan, T. Daniel Crawford, Heidi
M. Muchall, Xavier Fradera, David van der Spoel, Michael Braunschweig,
Antonio Marquez Cruz.  Thank you all.

Here are their individual responses in the order received:

Response 1:  Rajendra Zope 
==========================
From: Rajendra Zope <[email-masked]>

I am also in need of a package which can merge two or more  postscript
files into a single file. Please kindly notify me or summarize the
responses to your querry.

Rajendra Zope
---------------------------------------------------------------------------
Rajendra Zope                       e-mail: [email-masked]
 DRFMC/SI2A                          e-mail: [email-masked]
 CEA-Grenoble                        Tel: 04 76 88 45 04
 17, rue des Martyrs                 FAX: 04 76 88 51 60
 F-38054 Grenoble Cedex 9
 FRANCE
--------------------------------------------------------------------

Response 2: Thomas Heine
========================
From: Thomas Heine <[email-masked]>

90 rotate
(rotates by 90 degrees)
100 100 translate
(translates in x/y direction which you will need to fix it to the place}
Make sure to put it behind the bounding box (the stuff with the %)

Thomas

Response 3:  Antonio Buljan
============================
From: Dr. Antonio Buljan <[email-masked]>

the command is rotate alpha,
where alpha is the angle.
Now, alpha can be positive or negative.
If you don't can do it, send the postscript file and I can fix it.
I have some experience with this matter.

Antonio

Response 4:  T. Daniel Crawford
===============================
From: T. Daniel Crawford <[email-masked]>

You could try (1) converting the PS file to a PNM using the pstopnm
utility,
(2) using pnmrotate to rotate the new image, and then (3) use pnmtops to
convert back to a PS file.  All three of these utilities are available
on RedHat Linux systems, but I don't recall where to find them for other
systems.  A web search might help you there.

-Daniel
--
T. Daniel Crawford                           Department of Chemistry
[email-masked]                          Virginia Polytechnic Institute and
www.chem.vt.edu/chem-dept/crawford              State University

Response 5:  Heidi M. Muchall
=============================
From: Dr. Heidi M. Muchall <[email-masked]>

just put 90 rotate for a counterclockwise rotation of 90 deg. or -90
rotate
for clockwise. Any other angle will work, too. You might have to adjust
the
translate values, too. How's it going at Mac?
Heidi
*************************************************************
Dr. Heidi M. Muchall     | e-mail: [email-masked]
Assistant Professor      |
Department of Chemistry  |
  and Biochemistry       |
Concordia University     | phone: (514) 848-3342
Montreal, Quebec H3G 1M8 |
Canada                   | fax: (514) 848-2868
*************************************************************

Response 6: Xavier Fradera
========================== 
From: Xavier Fradera <[email-masked]>

you could also try using Gsview. I'm not sure about it, but I think it
allows you to read a postscript file, change its orientation (i.e.,
portrait to landscape) and save it. Have a look at:
http://www.cs.wisc.edu/~ghost/

Xavier.

Response 7: David van der Spoel
===============================
From: David van der Spoel <[email-masked]>

put:
rotate angle
in front of the real code.

Groeten, David.
________________________________________________________________________
Dr. David van der Spoel         Biomedical center, Dept. of Biochemistry
s-mail: Husargatan 3, Box 576,  75123 Uppsala, Sweden
e-mail: [email-masked]    www: http://zorn.bmc.uu.se/~spoel
phone:  46 18 471 4205          fax: 46 18 511 755
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Response 8: Michael Braunschweig
================================
From: michael braunschweig <[email-masked]>

try the "rotation" package in latex. including the two ps files als
pictures you can rotate them and create a new one.

michael braunschweig
department of chemistry
university of dortmund
germany

Response 9: Antonio Marquez Cruz
================================
From: Antonio Marquez Cruz <[email-masked]>

my $0.02 contribution:

the command to rotate a file is

x rotate

where "x" is the rotation angle (positive as well as negative angles can
be used). Try different values until you get the best fit of your two
files. You may need also to translate your files at the same time.

Dr. Antonio M. Marquez
Dpt. of Physical Chemistry                      Dpto. de Quimica Fisica
University of Seville                           Universidad de Sevilla
E-41012 Seville (SPAIN)                         41012-Sevilla
Phone:  34-95-4557177                           FAX: 34-95-4557174

====================================================================

Cherif F. Matta