Subject: Question about ECP´s and Basis Sets

From: Stefan Konietzny <[email-masked]>
Date: Mon, 08 Jan 2001 11:42:27 +0100

I am not sure if this message got thru over the weekend, i sent it again, 
because confusion is getting worse.

Dear CCLers,

i have two questions about the usage of ECPs.

In Gaussian98 the ECPs and the related basis sets by Stevens,Basch,Kraus are 
implemented and are called by the keyword CEP4G. When i type CEP4G* i get a 
polarization function with (for Bi) d-exponent of zero. This makes no sense 
for me and is, if one uses not gfprint or gfinput to check the basis, very 
dangerous. By the way, it is not a minimal basis with four primitives but a 
valence double zeta with (41/41) contraction. In a table in the manual (p36) 
it is noted that polarization functions are not available for SDD 
ECP/Basissets but i get a d-function when i call SDD for Bismuth.

I woukd like to optimize d-functions on my own.

Q1:
Is it accurate to optimize d-polarization functions on atoms by varying the 
exponent and minimizing the energy on a level that takes electron correlation 
into account (say CISD), like Frenking (chem. phys. lett. 1993, 208, p237) 
did for the Hay and Wadt ECPs? Or should one calculate a few model compounds, 
like hydrides, halogenides or methyl substituted molecules and find a mean 
value for the exponent by minimizing the energy of those compounds?

Q2:
When i use an ECP for a heavy element like Bismuth, must i use an ECP and the 
corresponding basis of the same "family" for the lighter elements as well, or 
is it OK to use an all electron basis set with the same quality of the 
valence shell: For example to use 6-31g* together with SDD (Stuttgart, 
Dresden ECPs, with polarization function by definition), or CEP41G plus my 
own optimized polarization function?

Looking forward to hearing from you,

Stefan Konietzny.

---

From: "Stefan Fau" <[email-masked]>
Date: Mon, 8 Jan 2001 18:12:33 -0500

Hi Stefan,

generally the Stuttgart-Dresden ECP basis
sets do not include polarization functions.
The ECP basis sets of very heavy elements
are an exception. Look at e.g. the basis sets
for the halogens. Also, G9x does not have
a set of polarization functions to add to the
(usually) DZ valence basis sets.

To Q1:
A good question! It is usually difficult to
optimize exponents of ECP valence basis
sets with respect to the energy. The exponents
tend to get very large, meaning that the function
is used to describe core electrons which should
be described by the ECP only. Still, it might
work for polarization functions.

The Stuttgart-Dresden ECPs are optimized with
respect to excitation and ionization energies of
atoms. That is unambiguous.

Optimizing molecular energies is probably better,
but there are a few problems:
* The choice of molecules is not unambiguous
   and might influence the result.
* You might need to optimize the geometries
   for each basis set.
* It definitely takes longer than just calculating
   atoms.

Have a look at the papers of Stoll, Preuss et al.
I think there is a paper of M. Kaupp et al that
suggests a reparametrization of the halogen
basis sets based on results for some earth-
alkali-dihalides. That might be of interest with
respect to the "atom or molecules" question.

To Q2:
You do not need to use ECPs everywhere. It is
sufficient to use balanced valence basis set, as
you suggested. The Stuttgart-Dresden ECP
basis sets use different exponents for s- and
p-functions. 6-31G* and related basis sets
use identical exponents (sp shells). This speeds
up the AO-integral evaluation at the cost of
slightly worse basis set performance. It might be
better to use basis sets with individual s- and p-
exponents like Ahlrichs SVP, cc-pVDZ and
many more.

Yours,
              Stefan (too)
______________________________________________________________________
Dr. Stefan Fau                    |      [email-masked]
Quantum Theory Project     |     (352) 392-6714
University of Florida
Gainesville, FL 32611-8435