Subject: Re: CCL:babel development?

From: "Dr. Richard Wood" <[email-masked]>
Date: Mon, 15 Jan 2001 10:11:09 -0500

David van der Spoel wrote:

> Hi,
>
> Is anybody still actively developing/maintaining babel? The latest version
> (1.6) seems to be from 1996.
>
> Groeten, David.
> ________________________________________________________________________
> Dr. David van der Spoel         Biomedical center, Dept. of Biochemistry
> s-mail: Husargatan 3, Box 576,  75123 Uppsala, Sweden
> e-mail: [email-masked]    www: http://zorn.bmc.uu.se/~spoel
> phone:  46 18 471 4205          fax: 46 18 511 755
> ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This is an interesting question, because Babel is SUPPOSED to be able to read
CHARMM files as
input, yet it doesn't.  And since there is no program other than Quanta that
will allow one to easily
view CHARMM crd files, it would be nice to be able to convert them to some
other format,

Richard

--
Richard L. Wood, Ph. D.
Physical/Computational Chemist
Post-doctoral Associate
Cornell University, Ithaca, NY 14853

---

From: Mihaly Mezei <[email-masked]>
Date: Mon, 15 Jan 2001 11:21:27 -0500

> view CHARMM crd files, it would be nice to be able to convert them to some

Among the several options of my program Simulad is conversion from (among
others) Charmm CRD to PDB, Macromodel and some other formats. It also does
trajectory conversions and there is a (rudimentary) display option for the
SGI. It can be downloaded from
http://inka.mssm.edu/~mezei/simulaid .

Mihaly Mezei, 

Dept. of Physiology & Biophysics, Mount Sinai School of Medicine
           Voice: (212) 241-2186     Fax: (212) 860-3369|
                 WWW: http://
 adsr13.mssm.edu/domains/dept/facultyInfo.epl?objname=physbio&user=mezeim01

---

From: Geoff Hutchison <[email-masked]>
Date: Mon, 15 Jan 2001 10:39:22 -0600 (CST)

>> (1.6) seems to be from 1996.

Yes and no. I asked a very similar question a few months ago. Both Matt
Stahl and Pat Walters are assisting on a GPL'ed library called OELib, that
is essentially based on Babel. Matt said that at some point OELib should
probably be released as "Babel 2.0." At one point, there was a webpage at
<http://www.eyesopen.com/oelib/>

I use OELib in some of my work and it's pretty good and evolving 
relatively quickly. Hopefully it will soon have all the Babel translators
and then some.

> CHARMM files as input, yet it doesn't. 

As someone who's written some file translators, it's hard to know what the
problem might be without example files.

Cheers,
--
-Geoff Hutchison
Northwestern Chemistry

---

From: Nicolas Foloppe <[email-masked]>
Date: Mon, 15 Jan 2001 18:25:21 +0100

>view CHARMM crd files, it would be nice to be able to convert them to some

I would also very much like to know something about the status of babel
development.

In passing, RasMol allows to visualize charmm coordinate files. 

Nicolas Foloppe

=========================================
=  Nicolas Foloppe                      =
=  Center for Structural Biochemistry   =
=  Department of Bioscience             =
=  Karolinska Institutet                =
=  S-141 57 Huddinge, SWEDEN            =
=                                       =
=  email: [email-masked]     =
=  Phone: International + 46-8-6089193  =
=  Fax  : International + 46-8-6089290  =
=========================================

---

From: Rick Venable <[email-masked]>
Date: Mon, 15 Jan 2001 12:33:49 -0500

On Mon, 15 Jan 2001, Dr. Richard Wood wrote:
> This is an interesting question, because Babel is SUPPOSED to be
> able to read CHARMM files as input, yet it doesn't.  And since there
> is no program other than Quanta that will allow one to easily view
> CHARMM crd files, it would be nice to be able to convert them to
> some other format,
> --
> Richard L. Wood, Ph. D.

Actually, I believe that both Rasmol and VMD can read and display CHARMM
.crd files, and write them back out in PDB format.  For Rasmol, the
process requires using the command line, and can't be automated
easily; something like

load charmm file.crd
save pdb file.pdb

should handle the file format conversion.  Note, however, that there are
a few naming conflicts for amino acids between CHARMM and PDB, for both
residue names (HIS) and heavy atom names (ILE, C-terminal O).  For
molecules besides the standard 20 amino acids, e.g. cofactors and AA
analogs, there is considerably more divergence in naming.

My experiences with automated coordinate file conversion have, in
general, not been very good, esp. with Babel.  Conversions from
Cambridge FDAT to PDB are particularly bad; all the numeric atom labels
are discarded, and all carbons become simply 'C' instead of 'C1', 'C2',
etc.  I realize that these are arbitrary numeric labels assigned by the
crystallographer and don't necessarily correspond to IUPAC numbering,
but they would be useful if retained.  (I developed my own procedure,
using Cambridge 'quest' prog directly, and a little file editing.)

=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=
Rick Venable
FDA/CBER/OVRR Biophysics Lab
1401 Rockville Pike    HFM-419
Rockville, MD  20852-1448  U.S.A.
(301) 496-1905
[email-masked]
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=

---

From: Christian Pilger <[email-masked]>
Date: Mon, 15 Jan 2001 19:50:22 +0100

Dear CCLers,

I know, this is another off-topic question, but maybe somebody can help
me. I have onlty little experience with postscript files. Can someboy
point a way to me how I can directly convert postscript to EPS or TIFF ?
Are there non-commercial programs available that run on SGI ?

Regards,

Christian

-----------------------------------------------------------------

 Dr. Christian Pilger 

    Istituto di Strutturistica Chimica "Giordano Giacomello"
    C.N.R. - Sezione di Trieste
    Area Science Park - Basovizza
    Strada Statale 14 - Km. 163.5
    I-34012 Trieste/Italy

   Tel.: +39+040+226881
   Fax : +39+040+9221126
 e-mail: [email-masked]
 
-----------------------------------------------------------------

---

From: "Jim Kress" <[email-masked]>
Date: Mon, 15 Jan 2001 12:58:38 -0500

Try:

http://www.eyesopen.com/oelib.html

Jim

----- Original Message -----
From: "Geoff Hutchison" <[email-masked]>
To: "Dr. Richard Wood" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, January 15, 2001 11:39 AM
Subject: CCL:babel development?

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To
Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
[email-masked]

---

From: "Giulio Vistoli" <[email-masked]>
Date: Mon, 15 Jan 2001 17:03:27 +0100

Dear CCLers,
if you are interested in software able to manage several file formats
(included CHARMM CRD and Quanta MSF), I would like to suggest our VEGA
package that is downloadable at: http://users.unimi.it/~ddl
Best regards

        Giulio Vistoli

--
Dr. Giulio Vistoli
Ist. di Chimica Farmaceutica e Tossicologica
Viale Abruzzi, 42
I-20131 Milano (Italy)
Tel. +39-02-29502230
Fax +39-02-29514197
E-Mail: [email-masked]
WWW: http://users.unimi.it/~ddl

---

From: Ben Webb <[email-masked]>
Date: Mon, 15 Jan 2001 16:49:11 +0000 (GMT)

On Mon, 15 Jan 2001, Dr. Richard Wood wrote:

> Babel is SUPPOSED to be able to read CHARMM files as input, yet it
> doesn't.  And since there is no program other than Quanta that will
> allow one to easily view CHARMM crd files, it would be nice to be able
> to convert them to some other format

	This is a fairly simple bug to fix. Just apply the following
patch (to rdcharmm.c) and recompile.

	Ben

--- babel-1.6/rdcharmm.c        Tue Jan 21 15:52:39 1997
+++ babel1.6-2/rdcharmm.c       Fri Feb 12 14:51:16 1999
@@ -51,9 +56,9 @@
       Type(i)[1] = the_line[16];
       Type(i)[2] = '\0';
     }
-    sscanf(&the_line[22],"%lf",&X(i));
-    sscanf(&the_line[32],"%lf",&Y(i));
-    sscanf(&the_line[42],"%lf",&Z(i));
+    sscanf(&the_line[21],"%lf",&X(i));
+    sscanf(&the_line[31],"%lf",&Y(i));
+    sscanf(&the_line[41],"%lf",&Z(i));
   }
   result = assign_radii(mol);  
   result = assign_bonds(mol);

---

From: Simon BERNECHE <[email-masked]>
Date: Mon, 15 Jan 2001 14:15:03 -0500

> In passing, RasMol allows to visualize charmm coordinate files. 

There's also DINO ( http://www.bioz.unibas.ch/~xray/dino ) that will
read CHARMM coordinate (.crd) and trajectory (.dcd)  files.  DINO gives high
resolution output in TIFF, PNG and PostScript formats or it may
also write input files for Raster3D and Povray. 

Simon

**********************************************************************************
  Simon BERNECHE
  --------------                                                         
  Département de physique - Université de Montréal                           
  Biochemistry Department - Weill Medical College of Cornell University      

  eMail: [email-masked]         Tel: (212) 746-4237 
**********************************************************************************