Subject: Re: CCL:Programming language

From: "Anthony J. Duben" <[email-masked]>
Date: Wed, 31 Jan 2001 13:05:58 -0600

I hope that this discussion does not become a religious
war, but I believe that any modern language would be
quite suitable -- C, FORTRAN, C++, JAVA -- are all good
candidates.  You are not training chemists to maintain
legacy code (much of which is in FORTRAN, plenty is in C,
and some more in C++).  You want the students to learn
how to think algorithmically.  JAVA is a good candidate
because of its object-orientation is more thoroughly
part of it than C++.  By the time the students graduate
and maybe finish grad school, whatever language they learn
now will have gone through another 3 editions.  

So, I would urge the students to get on with it and
really work hard at it.  The hardest computer language
to learn is the first one in which they need to learn
how to think in algorithms.  The next one to learn is
a lot easier.

Anthony J. Duben ([email-masked])

********************************************************
Anthony J. Duben
Professor and Chairman
Computer Science Dept., MS 5950
Southeast Missouri State University
1 University Plaza
Cape Girardeau MO 63701-4799
phone:  573-651-2194
fax:         573-651-2791 
e-mail: [email-masked]
  or        [email-masked]

"Education is not the filling of a pail
  but the lighting of a fire."
		  -- William Butler Yeats

"Amateurs talk strategy; 
 professionals talk logistics."
                       -- Gen. Omar N. Bradley

---

From: Lakshmi Devi Kesavan <[email-masked]>
Date: Wed, 31 Jan 2001 18:10:38 -0600 (CST)

Hello all,

While ccl is discussing about programming languages, I would like to get
more information on self-learning fortran.
Please recommend 1. web tutorials; 2. good easy-to-follow books; or any
other resources.

Thanks in advance,

Lakshmi

************************* 
Lakshmi S Devi Kesavan 
Graduate Student 			1012, 27th Ave SE,
Department of Chemistry			Apt # A
207, Pleasant Street S.E, 		Minneapolis, 
University of Minnesota			MN-55414 
Minneapolis, MN 55455-0431

Off # : 612-625-5325			
*************************