Subject: CCL:programming language

From: Joao <[email-masked]>
Date: Fri, 2 Feb 2001 12:56:20 +0000

Just my experince:

I learned BASIC at university (biochemistry course). The focus was on
algorithms and programing techniques that are usefull for numerical
calculations. 

QBASIC was inexpensive (we were programming at home -- a real bonus) and
provided a fast learning curve of the technicalities of the programming
language, allowing us (the students) to concentrate on learning how to solve
problems with computers. QBASIC is a structured language and what I have
learned has been easily applied using first c and recently c++.

I think students would prefer to learn a ubiquitous general pourpose
language instead of a group of specialised languages, each with their set of
features and faults. Coding in c and c++ can be simple and used for
inumerous different pourposes. Only if the specific task at hand is complex
and important enough,I consider learning a new language.

-- 
 Joao Sousa
 Instituto Gulbenkian de Ciencia
 Apartado 14, Rua da Quinta Grande, 6
 2781 Oeiras Codex
 Portugal

 TEL: +351-1-214407900 ext 317 
 FAX: +351-1-214407970

---

From: Deepak <[email-masked]>
Date: Fri, 2 Feb 2001 11:10:37 -0800 (PST)

Hi all

HAven't learnt programming the hard way, I must say I
totally agree.  THe specific language is not half as
important as programming principles and logic and of
course an open mind.

Regards

Deepak  

Tom Sundius  wrote: So now we have also got this
language debate here in CCL.I have the same opinion as
James. It is not so important whatcomputer language is
being taught in introductory programmingcourses for
science students. It is more important that somesimple
principles of programming are taught, and for that
purposeyou can use Fortran, C, C++, Java,... I have
taught introductoryprogramming courses for Physics
students for many years now.In the beginning I used
Pascal, but later on I switched over toFortran (lately
Fortran 90). One of my colleagues gives asimilar
course based on C.Object-oriented stuff etc. can be
saved for more advanced courses.In the beginning it is
most important to get some familiarity withprinciples.
We usually start with MATLAB, which is easier, since
programswritten in MATLAB can be immediately checked.
After that we proceed tosimple programming.On Thu, 1
Feb 2001, Robinson, James wrote:> These students will
need jobs and you must give the skills they will need
in> an ever evolving workplace. How many companies use
Fortran as opposed to> C++/Java? The ability to
program comes from the ability to think in the>
correct manner, not from learning a single language.
Joe Leonard is right in> declaring that programming
skills are more important that language>
familiarity.>> James>....Greetings,TomTom
SundiusUniversity of Helsinki, Department of Physics
phone +358-9-191 8339P.O.Box 9, FIN-00014 Helsinki,
Finland fax +358-9-191 8680-= This is automatically
added to each message by mailing script
=[email-masked] -- To Everybody |
[email-masked] -- To [email-masked]
-- HELP CHEMISTRY or HELP
[email-masked] -- archive search |
Gopher: gopher.ccl.net 70Ftp: ftp.ccl.net | WWW:
http://www.ccl.net/chemistry/ | Jan: [email-masked]

__________________________________________________
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/