Subject: RE: Kernel Update

From: "Fulton CR (Charles)" <[email-masked]>
Date: Thu, 1 Mar 2001 08:46:47 -0500

imho it's easier, and in the long run more useful, to download the kernel
source from ftp.<countrycode>.kernel.org and compile the kernel yourself. It
just sounds scary ;) After you get used to it you can have a new kernel
running in 10-15 min's. 

however, if you do want to use rpm's you might want to check out this
document here: 

http://www.redhat.com/support/docs/howto/kernel-upgrade/kernel-upgrade.html

The latest kernel rpm from redhat is kernel-2.2.17-14, found here: 

(redhat's errata page)
http://www.redhat.com/support/errata/RHSA-2001-013.html

good luck!

-charlie.

-----------------------------------------------------
Charles Fulton
Computational Chemistry
The Dow Chemical Company
S. Charleston, WV
-----------------------------------------------------

> ----------
> From: 	Max[SMTP:[email-masked]]
> Sent: 	Monday, February 26, 2001 5:00 PM
> To: 	Computational Chemistry List
> Subject: 	CCL:Kernel Update 
> 
> Hi CCLers
> 
> I hope to get some advice from you guys, I'm trying to update my Kernel,
> to correct the NAN problem with heavy jobs in 2.2.14-5 kernel.
> 
> When I try to rpm the kernel I get this anoying message:
> 
> # rpm -i kernel-smp-2.2.17-14.i386.rpm
> error: failed dependencies:
> rpmlib(VersionedDependencies) <= 3.0.3-1 is needed by
> kernel-smp-2.2.17-14
> 
> 
> I haven't been able to update RPM package because it sends me a lot of
> this errors:
> 
> file /bin/rpm from install of rpm-3.0.5-9.6x conflicts with file from
> package rpm-3.0.4-
> 
> Can anybody help me figure it out what is the problem??
> 
> Would RH7.0 be a better choice than updataing the kernel ??, any
> experience with gaussian, gamess, or nwchem on RH7.0 ???
> 
> I will Thank you a lot !
> Max
> 
> -
>  BE CAREFUL NOT TO BECOME TOO GOOD OF A SONGBIRD OR
>  THEY'LL THROW YOU INTO A CAGE.
> 
>                                     -- SNOOPY TO WOODSTOCK
> 
> 
> 
> 
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To
> Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
> 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
> [email-masked]
> 
> 
> 
> 
>

---

From: Jan Labanowski <[email-masked]>
Date: Thu, 1 Mar 2001 11:35:18 -0500 (EST)

You can also look at my instructions on installing Oracle under RH6.2 Linux
which has a step by step log of my commands for recompiling linux kernel.
You just skip the part where I change the header files: shmparam.h and
sem.h since this is only really needed for Oracle.

    http://www.ccl.net/cca/software/UNIX/oracle/RH6.2/

Jan

> http://www.redhat.com/support/errata/RHSA-2001-013.html

Jan K. Labanowski            |    phone: 614-292-9279,  FAX: 614-292-7168
Ohio Supercomputer Center    |    Internet: [email-masked] 
1224 Kinnear Rd,             |    http://www.ccl.net/chemistry.html
Columbus, OH 43212-1163      |    http://www.ccl.net/

---

From: "William F. Polik" <[email-masked]>
Date: Thu, 01 Mar 2001 14:45:44 -0500

While we are on the subject of updating Linux kernels, here is our internal 
documentation on updating the Red Hat 6.2 kernel.  This approach does NOT 
rebuild the kernel, but rather installs updated, pre-built Red Hat rpm 
packages.  Also, note that a newer version of the kernel rpm's exists than 
is specifically referenced in this procedure.

==========Updating the RedHat Linux 6.X kernel==========

Backup /boot directory
         # mkdir /boot.000
         # cd /boot
         # tar cf - . | (cd ../boot.000; tar xvf -)

Backup lilo.conf
         # cp -p /etc/lilo.conf /etc/lilo.conf.000

Note installed kernel packages
         # rpm -qa | grep kernel-
         kernel-headers-2.2.14-5.0
         kernel-2.2.14-5.0
         kernel-pcmcia-cs-2.2.14-5.0
         kernel-utils-2.2.14-5.0

Access kernel updates (here from another mount point)
         # mount -t vfat -r /dev/hda5 /mnt/hd
         # cd /mnt/hd/Updates/6.2i386/kernel
         # ls -alF

Install (not update!) updated or additional kernel packages, using --force 
option where necessary
         # rpm -ivh kernel-headers-2.2.16-3.i386.rpm
         # rpm -ivh kernel-2.2.16-3.i386.rpm
         # rpm --force -ivh kernel-pcmcia-cs-2.2.16-3.i386.rpm
         # rpm --force -ivh kernel-utils-2.2.16-3.i386.rpm
Note that the previous kernel will no longer support pcmcia due to 
overridden conflicts

Update lilo.conf by adding a new section for the new kernel and making it 
the default
         # pico /etc/lilo.conf
                 image=/boot/vmlinuz-2.2.16.3            [new section]
                         label=linux
                 image=/boot/vmlinuz-2.2.14-5.0          [renamed section]
                         label=linux-old

Update the boot record
         # /sbin/lilo -v

Reboot the system
         # shutdown -r now

Make a new emergency boot floppy
         # uname -r
         2.2.16-3
         # mkbootdisk 2.2.16-3

====================

This procedure has worked well for us, but all usual disclaimers apply 
should you use the procedure!  Comments from kernel aficionados are of 
course welcome.

Will Polik

===================================================================
William F. Polik             email: [email-masked]
Department of Chemistry      url:   http://www.chem.hope.edu/~polik
Hope College                 phone: (616) 395-7639
35 East 12th Street          fax:   (616) 395-7118
Holland, MI  49422-9000
===================================================================