Subject: (Sad) news about insightII on Linux

From: Szilveszter Juhos <[email-masked]>
Date: Thu, 05 Apr 2001 15:44:41 +0000

Dear All,

Thank you for the many replies I've got about running this
software on Linux. Unfortunatelly seems still no much choice
for a Linux user, after years of requests nothing has
changed at MSI :( My setup is a brand-new nVidia (Vanta),
Linux based RH 7.1 and Icompiled the latest X 4.0.3 server
and added nVidia support. Rasmol/VMD gives beautiful
performance pity they are missing a lot of functionalities
we need.

Things one can do to get insightII access:

i)  insightII -axxess     quite horrible output especially
if you have to work with proteins

ii) get out your new nVidia card, and buy one that is
supported by the Xig servers (www.xig.com). (nVidia do not
want to release some details for developers, I can not found
out what is the business in that for them, so choose an
other card or send mail to nVidia ten times a day. At least
Xig was answering to my request not like MSI)

iii) the very last chance is to try out this procedure that
Malcolm (again) sent me. It was not working for me although
I spent three days with chaseing sysadmin to install
gcc/autoconf/etc on the SGI from freeware.sgi.com and
recopiling/setting up the things, find out library
dependencies (seems now it needs libX11 and libXext as well
not only libm.so). You can start it without rld errors with:

setenv _RLDN32_LIST
$HOME/Mesa/lib/libGL.so:/usr/lib32/libm.so:DEFAULT:/usr/lib32/libX11.so:/usr/lib32/libXext.so

(csh on the remote side) but still:
Loading Insight II using OpenGL graphics ...
XIO:  fatal IO error 14 (Bad address) on X server "echo:0.0"

      after 34 requests (31 known processed) with 0 events
remaining.
....
Couldn't get initial visual in app_init_display

That is all the improvement after 5 years (see the forwarded
mail below).

Szilva
PS: apart from it have nice day ;)
-----------------------------------
Malcolm Gillies wrote:

Hi Szilva,
[..]
Unfortunately I haven't got any new information, but I'm
very
curious to hear what you uncover.

Just after I sent out my summary, I did get the following
mail,
which may offer a clue as to how you might be able to get
things
running (see below).

cheers,

Malcolm
--
  Date: Fri, 7 Jul 2000 12:59:15 +1000
  From: Drake Diedrich <[email-masked]>
  Subject: Re: CCL:Summary: OpenGL on Linux and
Insight/Sybyl
  Message-ID: <[email-masked]>
  References: <[email-masked]>
<[email-masked]>
  In-Reply-To: <[email-masked]>;
> from [email-masked] on
Thu, Jul 06, 2000 at 12:49:21PM +0200

  On Thu, Jul 06, 2000 at 12:49:21PM +0200, Malcolm Gillies
wrote:
  >
  > Unfortunately, noone seems to have succeeded in getting
MSI Insight
  > (aka Biosym InsightII) working with a remote Linux
OpenGL display.
  > At first glance, this appears to be a minor problem with
Insight
  > recognizing the remote display type correctly, but there
may also be
  > other more subtle difficulties to overcome. I'd be
interested to know
  > MSI's response to this problem.
  >

     In the past (Biosym '95 IIRC) I've had insightII
running over the wire to
  a Linux box using pure Mesa with no hardware
acceleration.  This requires
  that you compile Mesa three times on the SGI (once for
each -o32, -n32, -n64
  compiler ABI), store the shared libraries in special
directories, and then
  set environment variables to force insight to use MesaGL
instead of the
  native SGI OpenGL.  The remote display does not need the
GLX option this
  way.  Obviously to results are quite slow, but it did work
for light use.

     In my case I put the environment setup in a short
script and typed

        mesa insightII

  mesa
  ----
  #!/bin/sh

  # libm also required due to lack of dependency support in
the SGI linker
  # I suppose.  Required by a few demo programs, larger
programs probably
  # already link to libm.

  export _RLD_LIST _RLD64_LIST _RLDN32_LIST

_RLD_LIST=/usr/lib/libm.so:/usr/local/Mesa/lib/libGL.so:DEFAULT

_RLD64_LIST=/usr/lib64/libm.so:/usr/local/Mesa/lib64/libGL.so:DEFAULT

_RLDN32_LIST=/usr/lib32/libm.so:/usr/local/Mesa/lib32/libGL.so:DEFAULT

  exec $*

---

From: [email-masked] (Dr. David N. Haney)
Date: Thu, 5 Apr 2001 21:41:22 -0700 (PDT)

Sorry I'm late here.  InsightII was never intended to work over X,
and it does not work very well between SGI's.  It was somewhat of
an accident that InsightII worked between SGI's but it required the
GL service.  Instead of creating true X support for InsightII they
created this stripped down version -axxess.  While the GL verion
works reasonably well between SGI's, if you do any significant
screen updates, it is very slow.  

Tripos does support full Sybyl over true X (it runs on a Linux system
fine).  While this is a nice feature, it also suffers from slow
speeds if there are many screen updates.

-- 
#########              David N. Haney, Ph.D.                 #########
#  Haney Associates                            Phone - 858-483-1197  #
#  5455 Westknoll Dr.                            FAX - 858-483-1046  #
#  La Jolla, CA 92037                       Email - [email-masked]  #
#################                                #####################