Subject: Re: CCL:About the Fortran I/O.

From: Andrew Emerson <[email-masked]>
Date: Fri, 20 Apr 2001 17:16:37 +0200

Try using the flush(unit) subroutine just after the write.
For example,

  call flush(6)

best wishes
Andy Emerson

At 06:04 PM 4/20/01 +0800, you wrote:
>Dear all.
>
>I am using the SGI IRIX system. The Fortran program might used the write 
>buffer. It will always write to disk at size of 4096 bytes once a time.
>
>Is there any method to force the program to write at once when required?
>
>Best regrads
>
>Chungen
>______________________________________
>Chungen Liu, Dr.
>Chemistry Department
>Nanjing University
>Nanjing, 210093
>China
>
>[email-masked]
>
>
>===================================================================
>ÐÂÀËÃâ·Ñµç×ÓÓÊÏä (http://mail.sina.com.cn)
>ÍøÀïÑ°ËýÇ§°Ù¶È!Ã»ÓÐ"ÁÄÓÑËÙÅä",ÔõÄÜ"³ÉË«³É¶Ô"? (http://newchat.sina.com.cn)
>
>
>-= This is automatically added to each message by mailing script =-
>[email-masked] -- To Everybody  | [email-masked] -- To Admins
>[email-masked] -- HELP CHEMISTRY or HELP SEARCH
>[email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
>Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]

------------------------
Dr Andrew Emerson
CINECA (High Performance Systems)
via Magnanelli, 6/3
40033 Casalecchio di Reno (BO)-ITALY
tel: +39-051-6171653, fax: +39-051-6132198
e-mail: [email-masked]

---

From: Gert von Helden <[email-masked]>
Date: Fri, 20 Apr 2001 17:12:39 +0200

Hi,

You can do a "call flush(unit)". See the (short) man page on flush.

Hope that helps,
Gert

At 6:04 PM +0800 4/20/01, cgliu wrote:
>Dear all.
>
>I am using the SGI IRIX system. The Fortran program might used the 
>write buffer. It will always write to disk at size of 4096 bytes 
>once a time.
>
>-¬¿Àˆ’…-µÁ×"" ¦” (http://mail.sina.com.cn)
>Õ¯¿Ô-ƒÀ›«ßƒ»!ˆª"-"¡Ÿ"-À‰”",'žŸÐ"„ŠÀ´„Š'"? (http://newchat.sina.com.cn)
>
>

-- 
*******************************************************
  Dr. Gert von Helden
  FOM Institute for Plasmaphysics Rijnhuizen
  Edisonbaan 14, 3439 MN Nieuwegein, The Netherlands
  http://www.rijnh.nl/
  e-mail: [email-masked]
  phone: (+31) 30 6096999, fax: (+31) 30 6031204