Subject: large files with G98 on Linux

From: uccatvm <[email-masked]>
Date: Wed, 5 Sep 2001 12:04:22 +0100 (BST)

Hi ccl'ers,

Has anybody managed to compile Gaussian on Linux with large file (>2Gb)
support? 

I have Red Hat 7.1, which supports large files (I tested that it does indeed).

I downloaded the large file libraries from the PGI web page (beta version).
Linked with these libraries, the resulting executable still cannot handle large
files.

I then recompiled Gaussian adding -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
to the C flags, but the resulting executable crashes with a core dump.

Any hints will be appreciated.

See you,

Tanja
-- 
  =====================================================================
     Tanja van Mourik                                                
     Royal Society University Research Fellow
     Chemistry Department 
     University College London    phone:    +44 (0)20-7679-4663      
     20 Gordon Street             e-mail:   work: [email-masked] 
     London WC1H 0AJ, UK                    home: [email-masked]     

     http://www.chem.ucl.ac.uk/people/vanmourik/index.html
  =====================================================================

---

From: Szilveszter Juhos <[email-masked]>
Date: Wed, 5 Sep 2001 16:39:03 +0000

> Any hints will be appreciated.

Try reiserfs (that is also included in 2.4 kernels) that is 
better in big file support than the default ext[23]. Try to 
give a try with an extra HD instead of re-installing the
whole machine.

Also recommended to use egcs instead of the default buggy RedHat
version of gcc like

$ env CC=egcs CXX=egcs++ make 

for compilation.

Szilva

---

From: Todd Raeker <[email-masked]>
Date: Wed, 5 Sep 2001 12:48:30 -0400

> $ env CC=egcs CXX=egcs++ make

If you have been able to compile G98 with anything other than the Portland 
Group compiler I/ (we all I am sure) would really be pleased to have you 
share with us how you did it.

Todd.

> Szilva
>
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net
> 70 Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan:
> [email-masked]

-- 
Todd Raeker
Department of Chemistry
University of Michigan
(734) 647-2867 Phone
(734) 615-6950 FAX

---

From: Nelson Henrique Morgon <[email-masked]>
Date: Wed, 5 Sep 2001 14:32:38 -0300 (BRT)

> share with us how you did it.

I have compiled G98 with g77, no in LINUX but for FreeBSD:
(www.freebsd.org)

#RUNF77 = pgf77
RUNF77 = g77

and I don't have any problem with 2GB limit. 
I carried out tests until 30GB ...

Nelson 

  NELSON HENRIQUE MORGON 
  Department of Physical-Chemistry
  Institute of Chemistry
  State University of Campinas (UNICAMP) 
  Postal Box: 6154 Zip Code: 13083-970                 
  CAMPINAS - SP - BRAZIL.                     
  Telephone: 55 (19) 3788-3157                    
  Fax: 55 (19) 3788-3023
  e-mail: [email-masked]
  HP: http://canario.iqm.unicamp.br