Subject: Re: CCL:Running Autodock3 under linux2

From: [email-masked]
Date: Tue, 9 Oct 2001 16:32:26 GMT

Hi David,
It seems to be a general problem for linux users.
Actually the problem is with smaller stack size in linux.So set the stack size 
to a larger size.
type in the shell:
ulimit -s 66666
the value is essentially any thing you like ( i.e of the order of 60 MB here)
Thr default for linux is 8MB. Keep increasing the stack size till it does not 
give core dump.
It should help..

Chinmoy Ranjan,
I.I.T Kanpur
India.

 Hello all,
> 
> I have recently compiled Autodock under redhat6.0 and the compilation
> went well except for a few warnings which didn't seem to be to bad.  I
> followed the instruction according to an online instruction document on
> compiling this software on redhat and everything went good, and most of
> the programs work in the suit.
> 
> However, the primary program autodock3 when run, after 5-10 seconds I
> get back an error:
> 
> "Segmentation fault (core dump)"
> 
> with no output or further error messages.  So I don't even know were to
> start with this problem.  I've repeated the process with the software
> included examples and I get the same error, so I believe this may be do
> to a faulty compilation.
> 
> Has anyone out there experience this kind of problem (under linux 2) or
> does any one have any info that might be helpful to solving this
> problem?
> 
> Thanks for everyone's comments.
> 
> David Smith
> 
> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
>

---

From: David Smith <[email-masked]>
Date: Tue, 09 Oct 2001 22:50:15 -0400

Hey there,

Thanks for your suggestion,  setting my stack size to unlimited got me
past the segmentation fault problem but I ended up with another.  Now
I'm getting another error:

"Floating Point exception (core dumped)"

Any Ideas???

Thanks to all,

David Smith