Subject: Re: CCL:QM program calculating forces exerted on point charges?

From: Nicolas Ferre <[email-masked]>
Date: Fri, 08 Feb 2002 08:50:05 +0100

Hi Hannes,

In fact, point charges can be considered (from the computational point
of vue) as "quantum atoms without basis functions (centered on the
corresponding nuclei) and with a partial atomic charge". It's what I
coded into G98 and it works well. You just have to put to your code (in
a fortran-like scheme):
	IF QUANTUM THEN
           DO AS USUAL
	ELSE
	   SKIP BASIS FUNCTIONS DEFINITION
	   CHARGE = CHARGEMM INSTEAD OF Z
	   ENDIF

That's enough.

Nicolas

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Nicolas FERRE' (PhD)
				 phone/fax : +39-0577-234278
Dipartimento di Chimica
Universita` di Siena             mailto:[email-masked]
via Aldo Moro
53100 SIENA (Italia)             http://ccmaol1.chim.unisi.it/
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: Paul Sherwood <[email-masked]>
Date: Fri, 08 Feb 2002 15:11:42 +0000

Hannes,

> Now I wonder if there are any QM programs which output these additional
> gradients by default (or probably by user request).  Since many QM programs
> already allow the calculation of energy/gradients with point charges, would it
> be difficult to enhance the program to compute these additional gradient?

GAMESS-UK (www.dl.ac.uk/CFS) uses the simple and general approach of treating
the point charges as atoms without basis functions, and therefore generates
the forces by default. The disadvantage is that for a large number of point
charges the memory requirement is greater than it should be.  There is also a
switch controlling whether the interactions between the point charges are
included/excluded from this calculation. We have also implemented a variant
in which the point charges can be "blurred" using Gaussian functions.
Incidentally, GAMESS-UK also has an interface to CHARMM.

Paul Sherwood

-- 
======================================================================
Dr Paul Sherwood,         email:  [email-masked]
CLRC Daresbury Lab,       tel:    +44-1925-603553
Warrington,               fax:    +44-1925-603634
WA4 4AD,  UK.             http:   http://www.cse.clrc.ac.uk
======================================================================