Subject: A little geometrical problem

From: "Logean Antoine" <[email-masked]>
Date: Thu, 28 Feb 2002 17:43:41 +0100

A little geometrical problem :

Taken a residue in a PDB file, how can I calculate the Cartesian
coordinates of CB when I know the coordinates of N, CA and C, the angle
N-CA-CB, C-CA-CB and the bond length CA-CB ? 

It seems to be trivial but I am unable to find a solution !

I am sure that somebody can help me.

In advance thank you

LOGEAN Antoine

---

From: Richard Gillilan <[email-masked]>
Date: Thu, 28 Feb 2002 13:18:56 -0500

Use the formula for rotation of a point about 
an arbitrary axis. You can find it derived in 
Goldstein's classical mechanics text
(and probably many other books). A google 
search "rotate a point about an axis" will turn
up lots of hits. There is also a matrix version
of the algorithm (Computer Graphics Foley and van Dam?)
and also a section written by Mike Pique in a volume
of Graphics Gems.

I believe the formula has an important historical connection
to theory of quaternions (Rodrigues rotation formula). 

Richard Gillilan
MacCHESS
Cornell

---

From: Richard Gillilan <[email-masked]>
Date: Thu, 28 Feb 2002 13:54:00 -0500

Ooops. Sorry Logean, I spoke too soon, 
although you should be able to use the formula
I suggested, it's not as simple as I thought.

Here's what I was thinking: 

Write down the the formula for rotation of 
CB about the C-CA axis. Do the same for rotation
of CB about the CA-N axis. Set them equal. This 
should give you 3 equations, 3 unknowns. Could 
be a mess to solve though, Perhaps someone can 
suggest a clever solution.

  Richard

---

From: Lakshmi Devi Kesavan <[email-masked]>
Date: Thu, 28 Feb 2002 11:58:34 -0600 (CST)

Hello,

	If you are using charmm, this can be done using the command 'IC
build' (one could refer to the doc file 'ic.doc') and then writing out
the cartesian coordinate of the molecule.
hope that helps.

Devi

************************* 
Lakshmi S Devi Kesavan 
Doctoral Candidate 			
Department of Chemistry			
207, Pleasant Street S.E, 		 
University of Minnesota			
Minneapolis, MN 55455-0431

Off # : 612-625-2909			
*************************

On Thu, 28 Feb 2002, Logean Antoine wrote:

> -= This is automatically added to each message by mailing script =-
> [email-masked] -- To Everybody  | [email-masked] -- To Admins
> [email-masked] -- HELP CHEMISTRY or HELP SEARCH
> [email-masked] -- archive search    |    Gopher: gopher.ccl.net 70
> Ftp: ftp.ccl.net  |  WWW: http://www.ccl.net/chemistry/   | Jan: [email-masked]
> 
> 
> 
> 
> 
>

---

From: Ingo Brunberg <[email-masked]>
Date: Fri, 1 Mar 2002 03:06:07 +0100 (CET)

Obviously this problem is not as trivial as it seems. Though I can
think of a rather complicated solution, I just want to point out, that
there is most likely no single solution. The point you are searching
is located on the intersection of two cones with the angles N-CA-CB
and C-CA-CB originating from CA. So there are three different cases:

1) N-CA-CB + C-CA-CB < N-CA-C: no solution
2) N-CA-CB + C-CA-CB = N-CA-C: one solution
3) N-CA-CB + C-CA-CB > N-CA-C: two solutions

Seems like the problem leads to a quadratic equation.

Regards,

Ingo

---

From: Daquan Gao <[email-masked]>
Date: Thu, 28 Feb 2002 19:49:45 -0500

That is about right. The condition No. 2) leads to inifinitely many
solutions.... The points of possible CB forms a circle. By the way, the
only anlges that satifsy this condition are: N-CA-C=180 !

Daquan

---

From: Daquan Gao <[email-masked]>
Date: Thu, 28 Feb 2002 20:46:59 -0500

I thought about this again, found my previous answer was not complete.
Condition 2) can be satified when N-CA-C <= 180. If N-CA-C = 180, there
are infinitely many solutions; when N-CA-C<180 and equals the sum of the
other two angles, one solution.

Regards,
daquan