Subject: Re: CCL:partial atomic charges for autodock3

From: amor san juan <[email-masked]>
Date: Sun, 28 Jul 2002 00:28:10 -0700 (PDT)

Matthew:

It is correct that 3D structure of ligand is needed
for QM calculations. To my understanding, Autodock is
based on Kollman united atom model which merges
non-polar H's(ADT do this) for simplified calculation.

Regarding optimization, I have the same dilemma. I
used either MM & semiempirical that results to
conformation with smaller yz coordinates & negative
smaller charges.Take a look to my experiments:

1) Control distributed file ben.pdbq when run by steps

   mkgpf3===> mkdpf3===>autogrid3===>autodock3
shows data as same as control.However,
2) ben.mol2 created from comm. molecular modeling
package used for same steps above showed no grid maps
for ACN atoms.

Kindly post to CCL the summary of your question's
reply(if any). This will give me a hint and you could
help me a lot through this.

Thanks in advance.

**************************
--- Matthew Lee <[email-masked]>
wrote:
> 	The Autodock documentation recommends calculating
> the ligand charges
> using AMPAC or MOPAC, but to only include *polar*
> hydrogens.  Isn't it
> incorrect to run QM calculations on molecules that
> have incomplete
> valencies, i.e. a carbon without its hydrogen(s)? 
> If one were to add all
> the hydrogens to a small molecule and do either a
> single point calculation
> or a geometry optimization for the partial atomic
> charges, and then remove
> the non-polar hydrogens, the molecule would then be
> far too negative.  
> 
> 	How are people using AMPAC/MOPAC in conjunction
> with Autodock?  Are
> you leaving all the non-polar hydrogens there, and
> designating an additional
> 'h' atom type to be included for the non-polar
> hydrogens in the .gpf? Or is
> everyone using the rule-based Gasteiger-Marsili
> charges?
> 
> 	Also, I am wondering about the hydrogens on the
> macromolecule.  From
> the documentation, it seems that all hydrogrens,
> even the non-polar ones,
> present in a protein's .pdbqs file will be
> considered H-bond donors (as long
> as the atom name starts with H).  I deduce this from
> 1) the statement that
> "When modeling hydrogen bonds explicitly, it is
> necessary to add polar
> hydrogens to the macromolecule.", which implies to
> only add polar hydrogens
> to the protein and 2) the fact that the .gpf file
> seems to only allow for C,
> N, O, S, H, X & M atom types in the macromolecule,
> without a separate type
> 'h' for non-polar hydrogens.  It seems that the
> available atom types for the
> macromolecule are frozen, in contrast to those for
> the ligands, which can be
> anything the user wants and can be as many as the
> user wants.
> Interestingly, the documentation says under the DPF
> section of the Appendix:
> 
> ------------------------
> types <string>
> Atom names for all atom types present in ligand. 
> Each must be a single
> character, and only one of: C, N, O, S, H, X, or M.
> ------------------------
> This seems erroneous, as I tried using an alternate
> atom name like P, or
> even more vaguely like J, and autodock3 has no
> problem as long as 1) an
> affinity map was created for that atom name by
> autogrid3, 2) the atom name
> appears in the "types" line of the .dpf, and 3) the
> ATOM_MAPS in
> "autocomm.h" is sufficiently large.
> 
> 	In the AMBER all atom force field, hydrogen bonds
> are treated
> implicitly by the electrostatics, with no explicit
> 12 10 LJ parameters.  Are
> there any thoughts in the community on doing the
> following for setting up
> the macromolecule:
> 1)including all hydrogens in the macromolecule 
> 2)using the AMBER partial atomic charges for all
> protein atoms
> 3)turning off all H-bond acceptors in the ligand by
> switching the ligand's
> explicit H-bond paramaters for "O-H" and "S-H " in
> the .gpf from "12 10" to
> "12 6".
> 
> 	Much thanks in advance for any feedback.
> 
> --Matt Lee
> 
>
*******************************************************************
> Matthew Randolph Lee, Ph.D.
> 
> Computational Scientist		phone:  (858)410-6534
> Lion Bioscience Inc.		fax:    (858)410-6665
> 9880 Campus Point Drive	      e-mail: 
> [email-masked]
> San Diego, CA  92121
>
*******************************************************************

Sincerely,
Amor San Juan
University of the Philippines-Diliman

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com

---

From: "xin Hu" <[email-masked]>
Date: Sun, 28 Jul 2002 11:51:48 -0500

partial atomic charges for autodock3I had some experience before, hopefully something I still remember is helpful.

1.  AutoDock3 uses polar-H for protein indeed, like the ligand. The polar-H are added using "Protonate" module of AutoDock. If you uses Sybyl, you should select " united atom H". Check the pdbqs file,  If there are non-polar H's, you should re-prepare the file.
2. You can modify the source code(the head file of AutoGrid&AutoDock " autocomm.h") to add any atome typy for the protein, such as "h" for the non-polarH. (or P if it is really needed for you in protein.). While all H included in the protein, surely you need the all-atom partial charge instead of kollman united atom charges. 
3. It seems you can simply modify the "gpfgen.awk" or "dpfgen.awk" to control the 12-6 and 12-10 parameters.
4. I am not familar with MOPAC, AutoDock3 recommand the Gesteger charge models for ligand (from Sybyl or Babel assigned it), and using Autotor to merger the non-polarH. If you prefer to QM charges, I think it should be the same, get the charges with all H, and then apply AUtotors.

good luck

Xin
***************************************
Xin Hu
Department of Pharmaceutical Sciences
College of Pharmacy
North Dakota State University
Fargo, ND 58105
Tel: 701-231-4307 (home)
       701-231-7159 (Office)
Fax: 701-231-8333
E-mail: [email-masked]
             [email-masked]
***************************************

  ----- Original Message ----- 
  From: Matthew Lee 
  To: [email-masked]' 
  Sent: Friday, July 26, 2002 6:21 PM
  Subject: CCL:partial atomic charges for autodock3

          The Autodock documentation recommends calculating the ligand charges using AMPAC or MOPAC, but to only include *polar* hydrogens.  Isn't it incorrect to run QM calculations on molecules that have incomplete valencies, i.e. a carbon without its hydrogen(s)?  If one were to add all the hydrogens to a small molecule and do either a single point calculation or a geometry optimization for the partial atomic charges, and then remove the non-polar hydrogens, the molecule would then be far too negative.  

          How are people using AMPAC/MOPAC in conjunction with Autodock?  Are you leaving all the non-polar hydrogens there, and designating an additional 'h' atom type to be included for the non-polar hydrogens in the .gpf? Or is everyone using the rule-based Gasteiger-Marsili charges?

          Also, I am wondering about the hydrogens on the macromolecule.  From the documentation, it seems that all hydrogrens, even the non-polar ones, present in a protein's .pdbqs file will be considered H-bond donors (as long as the atom name starts with H).  I deduce this > from 1) the statement that "When modeling hydrogen bonds explicitly, it is necessary to add polar hydrogens to the macromolecule.", which implies to only add polar hydrogens to the protein and 2) the fact that the .gpf file seems to only allow for C, N, O, S, H, X & M atom types in the macromolecule, without a separate type 'h' for non-polar hydrogens.  It seems that the available atom types for the macromolecule are frozen, in contrast to those for the ligands, which can be anything the user wants and can be as many as the user wants.  Interestingly, the documentation says under the DPF section of the Appendix:  

  ------------------------ 
  types <string> 
  Atom names for all atom types present in ligand.  Each must be a single character, and only one of: C, N, O, S, H, X, or M.

  ------------------------ 
  This seems erroneous, as I tried using an alternate atom name like P, or even more vaguely like J, and autodock3 has no problem as long as 1) an affinity map was created for that atom name by autogrid3, 2) the atom name appears in the "types" line of the .dpf, and 3) the ATOM_MAPS in "autocomm.h" is sufficiently large.

          In the AMBER all atom force field, hydrogen bonds are treated implicitly by the electrostatics, with no explicit 12 10 LJ parameters.  Are there any thoughts in the community on doing the following for setting up the macromolecule:

  1)including all hydrogens in the macromolecule 
  2)using the AMBER partial atomic charges for all protein atoms 
  3)turning off all H-bond acceptors in the ligand by switching the ligand's explicit H-bond paramaters for "O-H" and "S-H " in the .gpf > from "12 10" to "12 6".

  --Matt Lee 

  Computational Scientist         phone:  (858)410-6534 
  Lion Bioscience Inc.            fax:    (858)410-6665 
  9880 Campus Point Drive       e-mail:  [email-masked] 
  San Diego, CA  92121 
  *******************************************************************