Subject: 64-bit RISC machines - SUMMARY

From: Daniel Svozil <[email-masked]>
Date: Mon, 10 Mar 2003 09:48:07 +0100

Hi,

here is the summary of my knowledge about the use (and usefulness) of
64-bit RISC machines in computational chemistry. As the document is
8 pages long, I prepared PDF file that is attached to this e-mail (I
hope it will go through the system). If you have any questions, please
do not hesitate and contact me at [email-masked].

Hope you will find the list interesting.

Regards
  Dan

-- 
Daniel Svozil, PhD
Institute of Organic Chemistry and Biochemistry
and Center for Complex Molecular Systems and Biomolecules
http://www.molecular.cz/
Czech Republic

phone: +420-2-20 183 263

[===========================================
  From the CCL editor: [email-masked]

   Due to size, the PDF file is not attached to this message, but placed in CCL
   archive under: 
        http://www.ccl.net/chemistry/resources/overview/ 
   or
        http://www.ccl.net/cca/documents

   Namely: 
        http://www.ccl.net/cca/documents/64-bit_in_CC_summary.pdf 

================================================]

---

From: Konstantin Kudin <[email-masked]>
Date: Mon, 10 Mar 2003 08:24:01 -0800 (PST)

Daniel

 Good document on 64 bit computing in CC! IMO, it
could benefit substantially if the reasons for going
64 bits were explained more clearly.
 Specifically, it appears that pretty much every 32
bit application on every OS is stuck with the 2Gb RAM
limit (even outside of CC). That is very achievable
with the latest systems. Also, there are usually
limits on the size of temporary files on the hard
drive. Current hard drive sizes far exceed what some
CC applications could address in terms of disk space
in 32 bits.
 Thus, one could expect a pretty significant push from
all vendors/software developers to 64 bits. While x86
32 bit systems have become really competitive with
RISC systems in terms of CPU performance and memory
bandwidth, the addressable memory size is becoming the
major roadblock. Some calculations can't be run in 32
bits simply because the needed RAM and disk space
could not be allocated and addressed on the software
level. It is not a problem to leave a computer running
for a month, but what can one do if enough RAM can't
be allocated due to 32 bit limitations?
 From this perspective the upcoming x86-64 systems
under Linux could provide huge benefit to the CC
community. The addressable RAM and disk could go as
far as the limits of physical RAM and disk space, thus
enabling truly monstrous calculations on really cheap
systems.

 Regards,
 Konstantin

> do not hesitate and contact me at

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/