Subject: CCL: Ring detection

From: "Mark Thompson" <mark:at:arguslab.com>
Date: Mon, 29 Sep 2003 09:07:17 -0700

Here is a very nice method to detect rings:

"Efficient Exact Solution of the Ring Perception Problem"
Renzo Balducci and Robert S. Pearlman
J. Chem. Inf. Comput. Sci.  1994, 34, 822-831

I use this approach in ArgusLab and it's proven to be efficient and robust.

Cheers,
Mark

***************************
Mark Thompson, PhD
Planaria Software LLC
PO Box 55207
Seattle, WA  98155

mark:at:arguslab.com
http://www.arguslab.com
***************************

-----Original Message-----
From: Computational Chemistry List [mailto:chemistry-request:at:ccl.net]On
Behalf Of Richard Gillilan
Sent: Monday, September 29, 2003 5:54 AM
To: Geoff Hutchison
Cc: John McKelvey; chemistry:at:ccl.net
Subject: CCL:Ring detection

Do you know if any of these codes have published their method?
I have a paper somewhere (I think it was actually Journal of
Mathematical Chemistry) that gives a method, but also gives me the
impression that a fully-general algorithm is non-trivial task. I'll
try to dig it up. In my OrderFour code, Ryan Lilien and I simply
invented our own
tree-search method for doing this, but I have no proof of how
general it is ... certainly works on all the rings I have
encountered so far and also can find arbitrarily large rings.
Anyone is welcome to look at the code, it is C++. Just drop
me an email.

Richard

On Saturday, September 27, 2003, at 08:04 PM, Geoff Hutchison wrote:

>> Can anyone point me to a code [preferably fortran ,{I know}] for
>> determining rings and size for atoms, given a connectivity list?
>
> I can't point you to a Fortran code for it, but I can point you to
> several open source codes that do this:
>
> OpenBabel (C++): http://openbabel.sf.net/
> JOELib (Java): http://joelib.sf.net/
> CDK (Java): http://cdk.sf.net/
>
> There are undoubtedly other codes, but I'm the most familiar with
> these three.
>
> Cheers,
> -Geoff
>

---

From: Christoph Steinbeck <c.steinbeck_at_uni-koeln.de>
Date: Mon, 29 Sep 2003 21:11:38 +0200

Me too, me too...
I implemented the SSSR method by Figueras [1] as part of our
Chemistry Development Kit (CDK), http://cdk.sourceforge.net, and it is 
even more efficient and robust :-)

Cheers,

Chris

[1]	Figueras, J. Ring Perception Using Breadth-First Search. J. Chem. 
Inf. Comput.Sci. 1996, 36, 986-991.

-- 
Dr. Christoph Steinbeck (e-mail: c.steinbeck_at_uni-koeln.de)
Groupleader Junior Research Group for Applied Bioinformatics
Cologne University BioInformatics Center (http://www.cubic.uni-koeln.de)
Z|lpicher Str. 47, 50674 Cologne
Tel: +49(0)221-470-7426   Fax: +49 (0) 221-470-7786

What is man but that lofty spirit - that sense of enterprise.
... Kirk, "I, Mudd," stardate 4513.3..

Mark Thompson wrote:

> mark_at_arguslab.com
> From: Computational Chemistry List [mailto:chemistry-request_at_ccl.net]On
> Cc: John McKelvey; chemistry_at_ccl.net
> -= This is automatically added to each message by the mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
> and send your message to:  CHEMISTRY_at_ccl.net
> 
> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST_at_ccl.net 
> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs 
> 
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jkl_at_ccl.net (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
> 
> 
> 
> 
> 
> 
> 
>