Subject: Re: Re: CCL:spin contaminant

From: "6!Q8@W" <dxl:at:mail.ustc.edu.cn>
Date: Fri, 2 Apr 2004 9:13:36 +0800

Dear John#:

>I wouldn't trust the energy.  This is a fairly large spin contamination,
>though I have seen worse.  
What leads the conclusion above? 4.2666 or 3.7543 (see below)?

     S**2 before annihilation     4.2666,   after     3.7543

>You also might try doing an ROHF calculation first and see if that leads
>to a better quartet state, and then using that as a guess for B3LYP
>(using guess=read).
How can I know whether the quartet obtain by !!ROHF calculation  is better?
Also from the orbital populations ?

    Thank you for your help!!!!!!!!!!!!!!!!!
 				
!!!!!!!!!!!!!!!!!!!!!!!!!!!!Ding Xunlei
!!!!!!!!!!!!!!!!!!!!!!!!!!!!2004-04-02
______________________________________________
Ding Xunlei, Ph.D. Candidate
Open Laboratory of Bond Selective Chemistry
University of Science & Technology of China
Hefei, Anhui 230026, P.R.China
Tel.: 0086-551-3603418
Fax.: 0086-551-3602969
E-mail: dxl:at:mail.ustc.edu.cn
Http://www.bsc.ustc.edu.cn/~dxl
======= 2004-04-01 15:46:00 You have written: =======

>Hi,
>
>I wouldn't trust the energy.  This is a fairly large spin contamination,
>though I have seen worse.  I would look closely at the orbital populations
>(pop=NBO is useful for this) and consider if it is "reasonable" and
>possibly try and find a pure quartet by moving things around (using
>guess=alter from your previously converged SCF wavefunction).  You
>also might try doing an ROHF calculation first and see if that leads
>to a better quartet state, and then using that as a guess for B3LYP
>(using guess=read).
>
>           Good luck!  -  John
>
>On Thu, 1 Apr 2004, 6!Q8@W wrote:
>
>> Dear CCLs#:
>> 
>>     I did a calculation with B3LYP and the spin contaminant was:
>> !!!!
>>     S**2 before annihilation     4.2666,   after     3.7543
>> 
>>     Did the energy obtained in the calculation reliable ?
>> 
>>     Thank you for your help!!!!!!!!!!!!!!!!!
>>  				
>> !!!!!!!!!!!!!!!!!!!!!!!!!!!!Ding Xunlei
>> !!!!!!!!!!!!!!!!!!!!!!!!!!!!2004-04-01
>> ______________________________________________
>> Ding Xunlei, Ph.D. Candidate
>> Open Laboratory of Bond Selective Chemistry
>> University of Science & Technology of China
>> Hefei, Anhui 230026, P.R.China
>> Tel.: 0086-551-3603418
>> Fax.: 0086-551-3602969
>> E-mail: dxl:at:mail.ustc.edu.cn
>> Http://www.bsc.ustc.edu.cn/~dxl
>> 
>> 
>> 
>> 
>> 
>> 
>> -= This is automatically added to each message by the mailing script =-
>> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
>> and send your message to:  CHEMISTRY:at:ccl.net
>> 
>> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST:at:ccl.net 
>> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs 
>> 
>> If your mail is bouncing from CCL.NET domain send it to the maintainer:
>> Jan Labanowski,  jlabanow:at:nd.edu (read about it on CCL Home Page)
>> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
>> 
>> 
>> 
>> 
>> 
>> 
>
>
>.

= = = = = = = = = = = = = = = = = = = =

---

From: "6!Q8@W" <dxl$at$mail.ustc.edu.cn>
Date: Fri, 2 Apr 2004 8:54:24 +0800

Dear John#:

The initial spin state is  quartet .!!!!

E-mail: dxl$at$mail.ustc.edu.cn
======= 2004-04-01 10:37:00 You have written: =======

>The energy id reliable for the calculation you did, _but_ the  implied spin
>state is probably unknown!  What was the initial spin state specified?
>
>John McKelvey
>----- Original Message -----
>From: "6!Q8@W" <dxl$at$mail.ustc.edu.cn>
>To: "CCL" <chemistry$at$ccl.net>; "gausshelp" <help$at$gaussian.com>
>Sent: Wednesday, March 31, 2004 9:33 PM
>Subject: CCL:spin contaminant
>
>

---

From: "6!Q8@W" <dxl:at:mail.ustc.edu.cn>
Date: Fri, 2 Apr 2004 10:59:28 +0800

Dear John#:

!!!!Someone have said DFT calculaion has little contamination, and can not be checked from S**2.
Do you think so?

======= 2004-04-01 17:59:00 You have written: =======

>On Fri, 2 Apr 2004, 6!Q8@W wrote:
>
>> Dear John#:
>> 
>  I am assuming that you are requesting a quartet since:
>
>Quartet <==> S = 3/2
>
>S*(S+1) = 3/2 * 5/2 = 15/4 = 3.75
>
>But your wavefunction has:
>
>S**2 = 4.27 ==> S = 1.626
>
>which isn't hugely different from 1.5, but is still too large
>from my experience.  For example, this is what Gaussian 03 gives
>for a B3LYP/6-311G calculation on Ti+ (quartet):
>
> Annihilation of the first spin contaminant:
> S**2 before annihilation     3.7502,   after     3.7500
>
>> 
>  Look at the value of S**2 before projection to the quartet just
>like you did above.  By the way, I have done calculations before
>where it finished, and I happily jotted down the energy, only to
>later find that the spin was badly contaminated and the results were
>garbage.  So I have learned to ALWAYS look at the spin for open
>shell systems.  You are right to worry about this!
>
>>

---

From: "6!Q8@W" <dxl^at^mail.ustc.edu.cn>
Date: Fri, 2 Apr 2004 9:5:4 +0800

Dear CCL#:

!!!!I can't find it on the address you gived me, but find it elsewhere(see below). 
I think it is very useful to me. But my question isn't solved yet.

>Spin Contamination 
>David Young
>Cytoclonal Pharmaceutics Inc. 
>What is spin contamination
>Introductory descriptions of Hartree-Fock calculations (usually using Rootaan's Self Consistent Field (SCF) method) focus on singlet systems for which all electron spins are paired. By assuming that the calculations is restricted to having two electrons per occupied orbital, the computation can be done relatively easily. This is often referred to as a spin restricted Hartree-Fock calculation or RHF. 
>For systems with a multiplicity other than one, it is not possible to use the RHF method as is. Often an unrestricted SCF calculation (UHF) is performed. In an unrestricted calculation, there are two complete sets of orbitals, one for the alpha electrons and one for the beta electrons. Usually these two sets of orbitals use the same set of basis functions but different molecular orbital coefficients. 
>The advantage of unrestricted calculations is that they can be performed very efficiently. The disadvantage is that the wave function is no longer an eigenfunction of the total spin, <S2>, thus some error may be introduced into the calculation. This error is called spin contamination. 
>How does spin contamination affect results
>Spin contamination results in having wave functions which appear to be the desired spin state, but have a bit of some other spin state mixed in. This occasionally results in slightly lowering the computed total energy due to having more variational freedom. More often the result is to slightly raise the total energy since a higher energy state is being mixed in. However, this change is an artifact of an incorrect wave function. Since this is not a systematic error, the difference in energy between states will be adversely affected. A high spin contamination can affect the geometry and population analysis and significantly affect the spin density. 
>As a check for the presence of spin contamination, most ab initio programs will print out the expectation value of the total spin, <S2>. If there is no spin contamination this should equal s(s+1) where s equals 1/2 times the number of unpaired electrons. One rule of thumb which was derived from experience with organic molecule calculations is that the spin contamination is negligible if the value of <S2> differs from s(s+1) by less than 10. Although this provides a quick test, it is always advisable to double check the results against experimental evidence or more rigorous calculations. 
>Spin contamination is often seen in unrestricted Hartree-Fock (UHF) calculations and unrestricted M?ller-Plesset (UMP2, UMP3, UMP4) calculations. It is less common to find any significant spin contamination in DFT calculations, even when unrestricted Kohn-Sham orbitals are being used. 
>Unrestricted calculations often incorporate a spin annihilation step which removes a large percentage of the spin contamination from the wave function at some point in the calculation. This helps minimize spin contamination but does not completely prevent it. The final value of <S2> is always the best check on the amount of spin contamination present. In Gaussian, the option "iop(5/14=2)" tells the program to use the annihilated wave function to produce the population analysis. I am not aware of any programs that use the annihilated wave function to perform the geometry optimization. 
>Restricted open shell calculations
>It is possible to run spin-restricted open shell calculations (ROHF). The advantage of this is that there is no spin contamination. The disadvantage is that there is an additional cost in the form of CPU time required in order to correctly handle both singly occupied and doubly occupied orbitals and the interaction between them. As a result of the mathematical method used, ROHF calculations give good total energies and wave functions but the singly occupied orbital energies don't rigorously obey Koopman's theorem. 
>When it has been shown that the errors introduced by spin contamination are unacceptable, restricted open shell calculations are the best way to get a reliable wave function. 
>Within the Gaussian program, restricted open shell calculations can be performed for Hartree-Fock, density functional theory, MP2 and some semiempirical wave functions. The ROMP2 method does not yet support analytic gradients, thus the fastest way to run the calculation is as a single point energy calculation with a geometry from another method. If a geometry optimization must be done at this level of theory, a non-gradient based method such as the Fletcher-Powell optimization must be used (note that the G94 manual implies that this may not still be functional for all cases). 
>Spin projection methods
>Another approach is to run an unrestricted calculation then project out the spin contamination after the wave function has been obtained (PUHF, PMP2). 
>A spin projected result does not give the energy obtained by using a restricted open shell calculation. This is because the unrestricted orbitals were optimized to describe the contaminated state rather than being optimized to describe the spin projected state. 
>A similar effect is obtained by using the Spin Constrained UHF method (SUHF). In this method the spin contamination error in a UHF wave function is constrained by the use of a Lagrangian multiplier. This removes the spin contamination completely as the multiplier goes to infinity. In practice small positive values remove most of the spin contamination. 
>Half-electron approximation
>Semiempirical programs often use the half electron approximation for radical calculations. The half electron method is a mathematical technique for treating a singly occupied orbital in an RHF calculation. This results in a consistent total energy at the expense of having an approximate wave function and orbital energies. Since a single determinant calculation is used, there is no spin contamination. 
>The consistent total energy makes it possible to compute singlet-triplet gaps using RHF for the singlet and the half electron calculation for the triplet. Koopman's theorem is not obeyed for half electron calculations. Also, no spin densities can be obtained. The Mulliken population analysis is usually fairly reasonable. 
>Further information
>Some discussion and results are in
>W. J. Hehre, L. Radom, P. v.R. Schleyer, J. A. Pople "Ab Initio Molecular Orbital Theory" Wiley (1986) 
>An article that compares unrestricted, restricted and projected results is
>M. W. Wong, L. Radom J. Phys. Chem. 99, 8582 (1995) 
>Some specific examples and a discussion of the half electron method are given in
>T. Clark "A Handbook of Computational Chemistry" Wiley (1985) 
>A more mathematical treatment can be found in the paper
>J. S. Andrews, D. Jayatilake, R. G. A. Bone, N. C. Handy, R. D. Amos Chem. Phys. Lett. 183, 423 (1991) 
>SUHF results are examined in 
>P. K. Nandi, T. Kar, A. B. Sannigrahi Journal of Molecular Structure (Theochem) 362, 69 (1996) 
>An expanded version of this article will be published in "Computational Chemistry: A Practical Guide for Applying Techniques to Real World Problems" by David Young, which will be available from John Wiley & Sons in the spring of 2001. 
>
>
>
>
>
>======= 2004-04-01 11:19:00 You have written: =======
>
>>Hello,
>>
>>I've been trying to sort out similar problems and have found a somewhat
>>helpful article by David Young on Spin contamination.  You might want to
>>check this out, it can be found at
>>
>>www.ccl.net/cca/documents/dyoung/topics-orig/spin-cont.html
>>
>>
>>Anna Fuzery
>>University of Wisconsin - Madison
>>Department of Biochemistry - John Markley Group
>>433 Babcock Dr.
>>Madison, WI 53706-1544
>>(608) 262-4687 ext. 3118
>>fuzery^at^nmrfam.wisc.edu
>>
>>
>>
>>.
>

---

From: "6!Q8@W" <dxl)at(mail.ustc.edu.cn>
Date: Fri, 2 Apr 2004 10:56:49 +0800

Dear John#:

>The theoretical value for S**2=3.75 for 3 unpaired spins.  You seem to have
>gotten that pretty close after projection.

But someone told me I should check the S**2 before annihilation (which is S**2 before annihilation     4.2666,   after     3.7543),  not after  annihilation.

>Did you consider running ROB3LYP using the UHF solution to start?  That
>would have S**2=3.750000.

I found it is difficult to converge in RO calculation. Have you any suggestion?!!!!

E-mail: dxl)at(mail.ustc.edu.cn
======= 2004-04-01 20:46:00 You have written: =======

>The theoretical value for S**2=3.75 for 3 unpaired spins.  You seem to have
>gotten that pretty close after projection.
>
>Did you consider running ROB3LYP using the UHF solution to start?  That
>would have S**2=3.750000.
>
>John
>From: "6!Q8@W" <dxl)at(mail.ustc.edu.cn>
>To: "John McKelvey" <jmmckel)at(attglobal.net>; "CCL" <chemistry)at(ccl.net>
>Sent: Thursday, April 01, 2004 6:54 PM
>Subject: Re: Re: CCL:spin contaminant
>
>
>Dear John#:
>
>E-mail: dxl)at(mail.ustc.edu.cn
>>From: "6!Q8@W" <dxl)at(mail.ustc.edu.cn>
>>To: "CCL" <chemistry)at(ccl.net>; "gausshelp" <help)at(gaussian.com>

---

From: John Bushnell <bushnell)at(ultra.chem.ucsb.edu>
Date: Thu, 1 Apr 2004 18:02:04 -0800 (PST)

Quartet <==> S = 3/2

Which isn't hugely different from 1.5, but is still too large