Subject: Re: CCL:freezing atoms in g03 optimizations

From: Yohann Moreau <moreau[at]lctn.uhp-nancy.fr>
Date: Wed, 02 Jun 2004 16:21:28 +0200

Hello Joey,

If I understand, you just want to make a partial geometry optimization, i.e. without
moving some atoms of the molecule.
To do so, there are two ways in Gaussian : it depends if you use cartesian coordinates or
a z-matrix

In the first case, just put the flag "-1" between the atom type and its coordinates (see
my answer to Kadri a few days ago)
(just be careful not to put a non frozen atom in first which is atomatically frozen)

In the second, you'll freeze internal coordinates :
use the keyword "opt=z-mat"
write your Z matrix not with numerical values but with variables

after your Z matrix, you must give values to the variables : name of the variable follewd
by the value
(this is in fact the general way to write a Z-matrix, nothing new)
To freeze some values, juste put in first the set of variables, a blank line and second,
the set of constants.
I'm not sure to be clear enough, so here is an example :

# RHF/STO-3G opt=z-mat

title : methanol

0 1
C
H   1   R1
H   1   R1   2   A1
H   1   R1   2   A1   3 D1
O   1   R2   2   A1   3 -D1
H   5   R3   1   A2   2 D2

R1 1.083
R2 1.44
A1 109.47122
D1 120.0

R3 0.96
A2 104.48
D2 180.0

R1, R2, A1 and D1 will be allowed to vary whereas R3, A2 and D2 won't be.

I hope this will help you,

Yohann

Joey Harriman wrote:

> Hi,
>
> I am trying to do a geometry optimization on a large system which contains some atoms
> that are involved in a transition-state structure.  I would like to fix the portion of
> the molecule with the TS geometry and do an optimization on the rest of the atoms.
> What is the best method to freeze the TS atoms?  I have been looking at the
> ModRedundant function, but am unaware of how to create the secondary input after the
> zmatrix for this.  Any help would be greatly appreciated.
>
> Thanks in advance,
>
> Joe Harriman
>
> ----------------------------------
> Joe Harriman
> Computational Chemistry
> University of New Brunswick
> Room 228
> Toole Hall
> s808o[at]unb.ca
> ----------------------------------
>
> -= This is automatically added to each message by the mailing script =-
> To send e-mail to subscribers of CCL put the string CCL: on your Subject: line
> and send your message to:  CHEMISTRY[at]ccl.net
>
> Send your subscription/unsubscription requests to: CHEMISTRY-REQUEST[at]ccl.net
> HOME Page: http://www.ccl.net   | Jobs Page: http://www.ccl.net/jobs
>
> If your mail is bouncing from CCL.NET domain send it to the maintainer:
> Jan Labanowski,  jlabanow[at]nd.edu (read about it on CCL Home Page)
> -+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

--

               Yohann MOREAU, Doctorant
       Equipe de Chimie et Biochimie Thioriques
               UMR CNRS-UHP 7565 "SRMSC"
          BP 239, F-54506 Vandoeuvre-lhs-Nancy
http://www.lctn.uhp-nancy.fr/Etudiants/Yohann.Moreau.html

---

From: Alessandro Contini <alessandro.contini|at|unimi.it>
Date: Wed, 02 Jun 2004 16:49:01 +0200

Hi Joey,
yes, the modredundant optimization is a good choice. If you have gaussview the 
procedure is pretty symple trhough the reduntant coordinate editor. If you 
are not using gaussview it could be pretty challanging if your sistem is 
rather big. However you have to put your redundant specifications after a 
blank line at the end of the g03 input. If you need to freeze an atom 
coordinate (cartesian) you'll write 

X N0 F

where N0 is the atom number you want to freeze

if you want to freeze a bond lenght the syntax will be

B N1 N2 F

for an angle

A N1 N2 N3 F

and for a dihedral

D N1 N2 N3 N4 F

where Nn are the respective atom numbers

Hope this help

Alessandro 
 
Alle 20:51, martedl 1 giugno 2004, Joey Harriman ha scritto:
> Hi,
>
> I am trying to do a geometry optimization on a large system which contains
> some atoms that are involved in a transition-state structure.  I would like
> to fix the portion of the molecule with the TS geometry and do an
> optimization on the rest of the atoms. What is the best method to freeze
> the TS atoms?  I have been looking at the ModRedundant function, but am
> unaware of how to create the secondary input after the zmatrix for this. 
> Any help would be greatly appreciated.
>
> Thanks in advance,
>
> Joe Harriman
>
> s808o|at|unb.ca
> To send e-mail to subscribers of CCL put the string CCL: on your Subject:
> line and send your message to:  CHEMISTRY|at|ccl.net
>
> Send your subscription/unsubscription requests to:
> CHEMISTRY-REQUEST|at|ccl.net HOME Page: http://www.ccl.net   | Jobs Page:
> http://www.ccl.net/jobs
>
> Jan Labanowski,  jlabanow|at|nd.edu (read about it on CCL Home Page)

-- 
Alessandro Contini, Ph.D.
Istituto di Chimica Organica "Alessandro Marchesini"
Universit` degli Studi di Milano, Facolt` di Farmacia
Via Venezian, 21 20133 Milano 
Tel. +390250314480 Fax. +390250314476
e-mail alessandro.contini|at|unimi.it

---

From: Nicolas Ferré <nicolas.ferre:at:up.univ-mrs.fr>
Date: Wed, 02 Jun 2004 17:37:03 +0200

Hi,

The fastest way is to use the cartesian coordinates of your system 
instead of the redundant internal ones. Then in order to optimize only a 
subset of atoms, use the following notation:

Atom_i    0   X_i  Y_i  Z_i
Atom_j   -1   X_j  Y_j  Z_j

That means that you freeze the position of atom j while atom i is free 
to move. Then running a standard optimization job in REDUNDANT INTERNAL 
COORDINATES is still possible: OPT is enough if the number of atoms is 
less than 50, or use OPT=REDUNDANT. The internal coordinate builder will 
  add coordinates between active atoms, between active and frozen atoms 
but not between frozen atoms.

Hope this helps,

Nicolas

Alessandro Contini a icrit :
>>s808o:at:unb.ca
>>CHEMISTRY-REQUEST:at:ccl.net HOME Page: http://www.ccl.net   | Jobs Page:
>>http://www.ccl.net/jobs
>>
> 
> 

-- 
  Dr. Nicolas Ferre'
  Laboratoire de Chimie Theorique et de Modelisation Moleculaire
  UMR 6517 - CNRS Universite' de Provence
  Case 521 - Faculte' de Saint-Jerome
  Av. Esc. Normandie Niemen
  13397 MARSEILLE Cedex 20 (FRANCE)
  Tel : (+33)4.91.28.27.33              Fax : (+33)4.91.28.87.58