Subject: Re: CCL:CPU usage

From: "Pablo Vitoria" <qibvigap[at]lg.ehu.es>
Date: Tue, 8 Feb 2005 09:45:32 +0100

Hi,

I don´t have much experience with G03 under Windows, but if it is really a HT problem, you could try disabling HyperThreading in the BIOS and see what happens. I run G03 under Linux in a dual Xeon, and I disabled HT.

Pablo
  ----- Original Message ----- 
  From: Steve Bowlus 
  To: Rodrigo Pontes ; chemistry[at]ccl.net 
  Sent: Tuesday, February 08, 2005 4:08 AM
  Subject: CCL:CPU usage

  I have observed the same behavior with another quantum code on a machine with the same CPU/OS combination.  There was an earlier post to this list asking about what seemed to be a similar problem with the Xeon HT. 

  I tentatively interpret the behavior that the job is given 100% of one of the HT execution streams, while the other stream is largely kept idle.  I have not found a way to tune this behavior. If you look at ControlPanels >AdministrativeTools >ComputerManagement >Processors, you will see there are two CPUs shown.  These can be uninstalled, but I haven't tried uninstalling one.  Presumably, all CPU resources would be concentrated in a single execution stream, but I haven't found any documentation on this point.  I also haven't found anything to suggest the second "CPU" can be _re_installed.  

  I haven't talked to Intel or HP (who built my machine), either of whom could shed light on all these issues.  Seems a pity that information on such a feature (or limitation) of HT technology would not be made readily available.

  sb

   -----Original Message-----
  From: Computational Chemistry List [mailto:chemistry-request[at]ccl.net]On Behalf Of Rodrigo Pontes
  Sent: Monday, February 07, 2005 9:29 AM
  To: chemistry[at]ccl.net
  Subject: CCL:CPU usage

    Dear Colleagues,

    We are running Gaussian on a Windows XP/Pentiun-IV HT 3.2GHz machine. We observed (in the Task manager / performance) that the CPU usage is only around 60%. Have someone noticed the same problem? How could us set the configuration to a 100% CPU usage?

    Thanks in advance,

    Rodrigo M. Pontes
    Departemanto de Quimica
    Universidade Estadual de Maringa
    Brazil

----------------------------------------------------------------------------
    Yahoo! Acesso Gratis - Internet rapida e gratis. Instale o discador do Yahoo! agora.

---

From: Gustavo Seabra <seabra !! ksu.edu>
Date: Tue, 08 Feb 2005 12:46:27 -0600

Pablo Vitoria wrote:

> Hi,
>  
> I don4t have much experience with G03 under Windows, but if it is 
> really a HT problem, you could try disabling HyperThreading in the 
> BIOS and see what happens. I run G03 under Linux in a dual Xeon, and I 
> disabled HT.
>  
> Pablo
>
>     *From:* Steve Bowlus <mailto:chezbowlus !! goldrush.com>
>     *To:* Rodrigo Pontes <mailto:pontes_uem !! yahoo.com.br> ;
>     chemistry !! ccl.net <mailto:chemistry !! ccl.net>
>     *Sent:* Tuesday, February 08, 2005 4:08 AM
>     *Subject:* CCL:CPU usage
>
>     I have observed the same behavior with another quantum code on a
>     machine with the same CPU/OS combination.  There was an earlier
>     post to this list asking about what seemed to be a similar problem
>     with the Xeon HT.
>      
>     I tentatively interpret the behavior that the job is given 100% of
>     one of the HT execution streams, while the other stream is largely
>     kept idle.  I have not found a way to tune this behavior. If you
>     look at ControlPanels >AdministrativeTools >ComputerManagement
>     >Processors, you will see there are two CPUs shown.  These can be
>     uninstalled, but I haven't tried uninstalling one.  Presumably,
>     all CPU resources would be concentrated in a single execution
>     stream, but I haven't found any documentation on this point.  I
>     also haven't found anything to suggest the second "CPU" can be
>     _re_installed. 
>      
>     I haven't talked to Intel or HP (who built my machine), either of
>     whom could shed light on all these issues.  Seems a pity that
>     information on such a feature (or limitation) of HT technology
>     would not be made readily available.
>      
>     sb
>      
>      
>
>     *From:* Computational Chemistry List
>     [mailto:chemistry-request !! ccl.net]*On Behalf Of *Rodrigo Pontes
>     *Sent:* Monday, February 07, 2005 9:29 AM
>     *To:* chemistry !! ccl.net
>     *Subject:* CCL:CPU usage
>
>         Dear Colleagues,
>          
>         We are running Gaussian on a Windows XP/Pentiun-IV HT
>         3.2GHz machine. We observed (in the Task manager /
>         performance) that the CPU usage is only around 60%.
>         Have someone noticed the same problem? How could us set the
>         configuration to a 100% CPU usage?
>          
>         Thanks in advance,
>          
>         Rodrigo M. Pontes
>         Departemanto de Quimica
>         ------------------------------------------------------------------------
>         Yahoo! Acesso Gratis
>         <http://br.rd.yahoo.com/mail/taglines/*http://br.acesso.yahoo.com/>
>         - Internet rapida e gratis. Instale o discador do Yahoo! agora.
>
AFAIK, the HT actually makes a second "virtual" CPU. In this case, 
wouldn't using %NProc=2 in the Gaussian input file help? If it works, 
that would likely be true for the Fedora version as well.

-- 
----------------------------------
Gustavo Seabra - Graduate Student
Chemistry Department
Kansas State University
----------------------------------
If at first you don't succeed...
      ...skydiving is not for you.