Subject: Re: CCL:CPU usage

From: "Tamas E. Gunda" <tgunda {} puma.unideb.hu>
Date: Tue, 8 Feb 2005 08:57:26 +0100

I think it is not depending on the hardware, but the code: how it was written, how it was compiled, how the threads are organized and used etc. You can add more or less priority to a program/process from the task manager, but it influences only the time sharing of the running processes: a low priority process can run quick too (such as the Seti), when no other big applications are used simultaneously, and vice versa. On the other hand, the CPU usage heavily depends on what the program is actually doing. For example when some geometry optimization is done on a PC by Gamess using ab initio method, the displayed CPU usage values are between 10 and 99%
  .----- Original Message ----- 
  From: Steve Bowlus 
  To: Rodrigo Pontes ; chemistry {} ccl.net 
  Sent: Tuesday, February 08, 2005 4:08 AM
  Subject: CCL:CPU usage

  I have observed the same behavior with another quantum code on a machine with the same CPU/OS combination.  There was an earlier post to this list asking about what seemed to be a similar problem with the Xeon HT. 

  I tentatively interpret the behavior that the job is given 100% of one of the HT execution streams, while the other stream is largely kept idle.  I have not found a way to tune this behavior. If you look at ControlPanels >AdministrativeTools >ComputerManagement >Processors, you will see there are two CPUs shown.  These can be uninstalled, but I haven't tried uninstalling one.  Presumably, all CPU resources would be concentrated in a single execution stream, but I haven't found any documentation on this point.  I also haven't found anything to suggest the second "CPU" can be _re_installed.  

  I haven't talked to Intel or HP (who built my machine), either of whom could shed light on all these issues.  Seems a pity that information on such a feature (or limitation) of HT technology would not be made readily available.

  sb

   -----Original Message-----
  From: Computational Chemistry List [mailto:chemistry-request {} ccl.net]On Behalf Of Rodrigo Pontes
  Sent: Monday, February 07, 2005 9:29 AM
  To: chemistry {} ccl.net
  Subject: CCL:CPU usage

    Dear Colleagues,

    We are running Gaussian on a Windows XP/Pentiun-IV HT 3.2GHz machine. We observed (in the Task manager / performance) that the CPU usage is only around 60%. Have someone noticed the same problem? How could us set the configuration to a 100% CPU usage?

    Thanks in advance,

    Rodrigo M. Pontes
    Departemanto de Quimica
    Universidade Estadual de Maringa
    Brazil

----------------------------------------------------------------------------
    Yahoo! Acesso Gratis - Internet rapida e gratis. Instale o discador do Yahoo! agora.

---

From: Victor Manuel Rosas-Garcia <quimico69-.at.-yahoo.com>
Date: Tue, 8 Feb 2005 06:10:41 -0800 (PST)

I had a similar problem when running GAMESS under Fedora Core 2.  Then I
disabled hyperthreading, from the setup menu upon starting the machine, and cpu
usage went up to 100%.

When I installed the OS, the Fedora Core 2 installer setup two kernels, one for
1 CPU and the SMP variety.  After disabling hyperthreading I had to  make sure
the machine always runs the kernel for 1 CPU so that I get 100% CPU usage.

--- Steve Bowlus <chezbowlus-.at.-goldrush.com> wrote:

> I have observed the same behavior with another quantum code on a machine
> with the same CPU/OS combination.  There was an earlier post to this list
> asking about what seemed to be a similar problem with the Xeon HT.
> 
> I tentatively interpret the behavior that the job is given 100% of one of
> the HT execution streams, while the other stream is largely kept idle.  I
> have not found a way to tune this behavior.  If you look at ControlPanels
> >AdministrativeTools >ComputerManagement >Processors, you will see there are
> two CPUs shown.  These can be uninstalled, but I haven't tried uninstalling
> one.  Presumably, all CPU resources would be concentrated in a single
> execution stream, but I haven't found any documentation on this point.  I
> also haven't found anything to suggest the second "CPU" can be
> _re_installed.
> 
> I haven't talked to Intel or HP (who built my machine), either of whom could
> shed light on all these issues.  Seems a pity that information on such a
> feature (or limitation) of HT technology would not be made readily
> available.
> 
> sb
> 
> 
> 
> From: Computational Chemistry List [mailto:chemistry-request-.at.-ccl.net]On
> Behalf Of Rodrigo Pontes
> To: chemistry-.at.-ccl.net
> Subject: CCL:CPU usage
> 
> 
>   Dear Colleagues,
> 
>   We are running Gaussian on a Windows XP/Pentiun-IV HT 3.2GHz machine. We
> observed (in the Task manager / performance) that the CPU usage is only
> around 60%. Have someone noticed the same problem? How could us set the
> configuration to a 100% CPU usage?
> 
>   Thanks in advance,
> 
>   Rodrigo M. Pontes
>   Departemanto de Quimica

=====
Victor M. Rosas Garcma
Theoretical Chemistry Apprentice

e-mail: quimico69-.at.-yahoo.com

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com