Subject: vector file on Xmol

From: [email-masked] (Earl EVLETH p 74208)
Date: Thu, 15 Dec 1994 17:17:33 +0000 (MET)

If anyone has an example of the use of the VECTOR
file option on the XMOL graphic soft I would appreciate 
it. I have not been able to extract this 
information from the XMOL manual is understandable form
and the manual does not offer sample input files for
such a simple case. The manual states that it can be
included in the XYZ file and except to generating atomic
charges.

Thanks in advance.  

E. M. Evleth ([email-masked])
Dynamique des Intereactions Moleculaires.
Universite Pierre et Marie Curie                                        
4 Place Jussieu, Tour 22, Paris, France 75240

---

From: [email-masked] (David C. Doherty)
Date: Thu, 15 Dec 1994 12:04:19 -0600 (CST)

>included in the XYZ file and except to generating atomic

Quoted from the XYZ file specification man page:

  Each line of text describing a single atom must  contain  at
  least  four  fields of information, separated by whitespace:
  the atom's type (a short string of alphanumeric characters),
  and  its  x-,  y-, and z-positions. Optionally, extra fields
  may be used to specify a charge for the atom, and/or a  vec-
  tor  associated  with  the  atom.  If an input line contains
  five or eight fields, the fifth field is interpreted as  the
  atom's  charge;  otherwise, a charge of zero is assumed.  If
  an input line contains seven or eight fields, the last three
  fields are interpreted as the components of a vector.  These
  components should be specified in angstroms.

You mean that's not clear?  ;)
--
Here are some examples (where Vx,Vy,Vz are the 
x,y, and z components of some vector):

-
hydrogen atom with x,y,z defined (charge zero is implied):

H  1.0  1.0  1.0                    [4 fields]
-
hydrogen atom with x,y,z,charge defined:

H  1.0  1.0  1.0  0.1               [5 fields]
-
hydrogen atom with x,y,z,charge,Vx,Vy,Vz defined:

H  1.0  1.0  1.0  0.1 0.5 0.5 0.5   [8 fields]
-
hydrogen atom with x,y,z,Vx,Vy,Vz defined 
(charge zero is implied):

H  1.0  1.0  1.0      0.5 0.5 0.5   [7 fields]

Hope that this helps. If not, send mail to [email-masked]
and we'll try to provide a more concrete example.

Dave Doherty
-- 

David C. Doherty
Minnesota Supercomputer Center
[email-masked]